summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/luckybackup
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/luckybackup')
-rw-r--r--app-backup/luckybackup/Manifest2
-rw-r--r--app-backup/luckybackup/luckybackup-0.4.7-r1.ebuild42
-rw-r--r--app-backup/luckybackup/luckybackup-0.4.8.ebuild53
-rw-r--r--app-backup/luckybackup/metadata.xml8
4 files changed, 105 insertions, 0 deletions
diff --git a/app-backup/luckybackup/Manifest b/app-backup/luckybackup/Manifest
new file mode 100644
index 000000000000..2fe8344209b1
--- /dev/null
+++ b/app-backup/luckybackup/Manifest
@@ -0,0 +1,2 @@
+DIST luckybackup-0.4.7.tar.gz 5393530 SHA256 492f27f9e846d5f11d9a4466aa821803b17eb7c3047f9cf082bc66be3d093f4d SHA512 87c62241327e731cd3b4d230d17e43de48bcf840cac938153b8cf321fe00209a649ff251c0c60eb6feb55582b597eaa3d1f6727d956fe75429ced93920c544ef WHIRLPOOL 4c2bd772d6b1271af3b937a0fbbae56e6ee434a068bb2be94e11cd3d86dfe18c6931bff76921f02f9ecf32cec4cb201e30c1bcfa88048b87db5ead8ba7808ae8
+DIST luckybackup-0.4.8.tar.gz 5710203 SHA256 68a8a318a6a32a2395fbaada114973f5a4887846c5c6188b38c175215b3116f6 SHA512 48e73f8b5897a09f64f3755dc094ef50031c607ecfca25c238b45ca5bef7f2645081b7c665a9b7c3c3da2f214f91b229a559d723df8ddb6446aa23e68b266076 WHIRLPOOL ccced074661d4a3764bf6e069aff5877c721ef3ef452490dfb17d292c0ee6cb1f12b995eea40134995c1a8ca935472ffcf28585b28d1d4818f06042e512aacec
diff --git a/app-backup/luckybackup/luckybackup-0.4.7-r1.ebuild b/app-backup/luckybackup/luckybackup-0.4.7-r1.ebuild
new file mode 100644
index 000000000000..bdd807860bb5
--- /dev/null
+++ b/app-backup/luckybackup/luckybackup-0.4.7-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit qt4-r2
+
+DESCRIPTION="Powerful and flexible backup (and syncing) tool, using RSync and Qt4"
+HOMEPAGE="http://luckybackup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}
+ net-misc/rsync"
+
+DOCS="readme/*"
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:g" \
+ -e "s:/usr/share/doc/packages/${PN}:/usr/share/doc/${PF}:g" \
+ luckybackup.pro src/global.h || die "sed failed"
+
+ # The su-to-root command is an ubuntu-specific script so it will
+ # not work with Gentoo. No reason to have it anyway.
+ sed -i -e "/^Exec/s:=.*:=/usr/bin/${PN}:" menu/${PN}-gnome-su.desktop \
+ || die "failed to remove su-to-root"
+
+ # causes empty directory to be installed
+ sed -i -e '/^INSTALLS/s/debianmenu //' luckybackup.pro \
+ || die "sed installs failed"
+
+ # remove text version - cannot remote HTML version
+ # as it's used within the application
+ rm license/gpl.txt || die "rm failed"
+}
diff --git a/app-backup/luckybackup/luckybackup-0.4.8.ebuild b/app-backup/luckybackup/luckybackup-0.4.8.ebuild
new file mode 100644
index 000000000000..2aa12f53fd70
--- /dev/null
+++ b/app-backup/luckybackup/luckybackup-0.4.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="bs ca cs de el en es fr it nl no pl pt_BR ro ru sk sl sv tr zh_TW"
+inherit l10n qt4-r2
+
+DESCRIPTION="Powerful and flexible backup (and syncing) tool, using RSync and Qt4"
+HOMEPAGE="http://luckybackup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}
+ net-misc/rsync"
+
+DOCS=( readme/{AUTHORS,README,TODO,TRANSLATIONS,changelog} )
+
+rm_loc() {
+ sed -i -e "s|translations/${PN}_${1}.ts||" "${PN}.pro" || die 'sed on translations failed'
+ rm "translations/${PN}_${1}."{ts,qm} || die "removing ${1} locale failed"
+}
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:g" \
+ -e "s:/usr/share/doc/packages/${PN}:/usr/share/doc/${PF}:g" \
+ luckybackup.pro src/global.h || die "sed failed"
+
+ # The su-to-root command is an ubuntu-specific script so it will
+ # not work with Gentoo. No reason to have it anyway.
+ sed -i -e "/^Exec/s:=.*:=/usr/bin/${PN}:" menu/${PN}-gnome-su.desktop \
+ || die "failed to remove su-to-root"
+
+ # causes empty directory to be installed
+ sed -i -e '/^INSTALLS/s/debianmenu //' luckybackup.pro \
+ || die "sed installs failed"
+
+ # remove text version - cannot remote HTML version
+ # as it's used within the application
+ rm license/gpl.txt || die "rm failed"
+
+ l10n_find_plocales_changes "translations" "${PN}_" ".ts"
+ l10n_for_each_disabled_locale_do rm_loc
+ qt4-r2_src_prepare
+}
diff --git a/app-backup/luckybackup/metadata.xml b/app-backup/luckybackup/metadata.xml
new file mode 100644
index 000000000000..2185e73b79c7
--- /dev/null
+++ b/app-backup/luckybackup/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <upstream>
+ <remote-id type="sourceforge">luckybackup</remote-id>
+ </upstream>
+</pkgmetadata>