summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnard <anard@free.fr>2022-03-14 07:44:19 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-03-18 16:00:19 +0200
commit998f751028cb5b98c35622e011309bcf94cf8ce4 (patch)
treef19ab14798dd31bfe9b1601a78c0f73e40b699fd /app-backup
parentdev-python/cloudscraper: update EAPI 7 -> 8 (diff)
downloadgentoo-998f751028cb5b98c35622e011309bcf94cf8ce4.tar.gz
gentoo-998f751028cb5b98c35622e011309bcf94cf8ce4.tar.bz2
gentoo-998f751028cb5b98c35622e011309bcf94cf8ce4.zip
app-backup/backintime: add 1.3.2, python-3.10
Closes: https://github.com/gentoo/gentoo/pull/24547 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/backintime/Manifest1
-rw-r--r--app-backup/backintime/backintime-1.3.2.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-backup/backintime/Manifest b/app-backup/backintime/Manifest
index 6c8ad7caafb0..ecccd0fb218d 100644
--- a/app-backup/backintime/Manifest
+++ b/app-backup/backintime/Manifest
@@ -1,2 +1,3 @@
DIST backintime-1.2.1.tar.gz 713853 BLAKE2B 0f05d6cdc04a41ec9737badb8693c1270bb1333b2986fce925625ba2d7be05de0630ff5f59a7b5854a38ba382d6992df1ffc4e1cb584cae0e2618b877db4f06b SHA512 91dbc76a7db81469c5a538be03196c8e307d13307486d8e1c6cad10ce0af399de495f0292fecffc2853ed78804b5899750f06f274b4701efe3af6a708ea1024e
DIST backintime-1.3.1.tar.gz 714401 BLAKE2B 5b6a294d5a22ee3928725caf1a9895b665bfcddd6b779355cd7f7e58b5a201c3d2158ef4b30fb73eb4525c1a54cacf878397874f28b06798b7bfd973df467a39 SHA512 faac8552748da75db62cf7fa7eea686fd8b262016d1072f432fff54a6c0c72929650582870b4c56efbaa4ef5984acaece9e1d76eb72abcce91c6fc92d34d52ad
+DIST backintime-1.3.2.tar.gz 714459 BLAKE2B cc53bd5391155705016248511e30cdfa7bc25f0a7cb170dfeeffda397e8be1b22f8e335063289d8c192f94c469430655064899ac8059f22f3b7582e3af87d373 SHA512 19f756d03cc7533e02bb5172ae3f8c167206bf5e8d60c0f3af1f647e01297a4eeb7889bbb5b58e46636bc31392ee436249b276ddbfa41697a0538c542fa26cb8
diff --git a/app-backup/backintime/backintime-1.3.2.ebuild b/app-backup/backintime/backintime-1.3.2.ebuild
new file mode 100644
index 000000000000..a22027e41a00
--- /dev/null
+++ b/app-backup/backintime/backintime-1.3.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-single-r1 xdg
+
+DESCRIPTION="Backup system inspired by TimeVault and FlyBack"
+HOMEPAGE="https://backintime.readthedocs.io/en/latest/ https://github.com/bit-team/backintime/"
+SRC_URI="https://github.com/bit-team/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples qt5"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ net-misc/openssh
+ net-misc/rsync[xattr,acl]
+ qt5? ( dev-python/PyQt5[gui,widgets] )"
+BDEPEND="sys-devel/gettext"
+
+PATCHES=( "${FILESDIR}/${PN}-1.2.1-no-compress-docs-examples.patch" )
+
+src_configure() {
+ pushd common > /dev/null || die
+ # Not autotools
+ ./configure --python3 --no-fuse-group || die
+ popd > /dev/null || die
+
+ if use qt5 ; then
+ pushd qt > /dev/null || die
+ ./configure --python3 || die
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ pushd common > /dev/null || die
+ emake
+ popd > /dev/null || die
+
+ if use qt5 ; then
+ pushd qt > /dev/null || die
+ emake
+ popd > /dev/null || die
+ fi
+}
+
+src_install() {
+ pushd common > /dev/null || die
+ emake DESTDIR="${D}" install
+ popd > /dev/null || die
+
+ if use qt5 ; then
+ pushd qt > /dev/null || die
+ emake DESTDIR="${D}" install
+ popd > /dev/null || die
+ fi
+
+ einstalldocs
+
+ if use examples ; then
+ docinto examples
+ dodoc common/{config-example-local,config-example-ssh}
+ fi
+
+ python_optimize "${D}"
+}