summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-07-29 11:21:54 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-08-13 10:36:26 +0300
commitaf8217c9e0a193b80d5a7da390d73774a4c254e8 (patch)
tree73386170b21e77366a6be169adf9e0b5bfb4bbd8 /app-backup
parentapp-backup/restic: drop 0.15.2 (diff)
downloadgentoo-af8217c9e0a193b80d5a7da390d73774a4c254e8.tar.gz
gentoo-af8217c9e0a193b80d5a7da390d73774a4c254e8.tar.bz2
gentoo-af8217c9e0a193b80d5a7da390d73774a4c254e8.zip
app-backup/restic: add 0.17.0
Closes: https://bugs.gentoo.org/936983 Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/37778 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/restic/Manifest2
-rw-r--r--app-backup/restic/restic-0.17.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/app-backup/restic/Manifest b/app-backup/restic/Manifest
index f8e264f6adc9..1d2be62e2894 100644
--- a/app-backup/restic/Manifest
+++ b/app-backup/restic/Manifest
@@ -2,3 +2,5 @@ DIST restic-0.16.4-deps.tar.xz 171826444 BLAKE2B 2b4adb002209bbdcd2884f0126b7757
DIST restic-0.16.4.tar.gz 23990246 BLAKE2B f8dff867ee5e0f9c16b3b22b7db7bfede6d38565558c99632e7239e9c6a19602cd7ea5c7761ac5d0103d6e07c68c0d20c64184317022799f19b9ac814c4b6ff4 SHA512 9f28f90466a30a3c1f32cd1951dddaa22d30ece8b1c18da1a907cc1dd0f98065c25529e855b56fc3d62801b052371d9fe117cd26f17e15276f6a9a309416e914
DIST restic-0.16.5-deps.tar.xz 172231640 BLAKE2B 76dafbaf761a62c3830fbb44f2f64ed45d752081f034a49772366edaf9a6b6b60a964cf16e08b9cfb35a7791ddfd39e7447d4e41287e74c65322e31ef431e1da SHA512 af338dcb2805ec8c83afffb8d5a0179617a26547354cddbdff583d7c8837285e2faedd033d3786ade55d444b0e9319dbe780b8f73bb3492d67447a5eabc3a3d1
DIST restic-0.16.5.tar.gz 23990221 BLAKE2B ffdbcbcd5cbd2c22009c7d9c58cbc943c542cdc8d11e2a41cd87df58e0319ec396d6d880396aaaca103012efdfbb68f4fa5d42bd7f3df9208f9b9d80b6dadf0d SHA512 57a1829e28c4317172c06e095d91d760466c589cc9d2f2a5f20491ffe60f7a7c60e4666377fa5ae275b3238c10c27ab9265ea4f9f98c34b288fbd1e70a0814c6
+DIST restic-0.17.0-deps.tar.xz 173393552 BLAKE2B fe5b89cabd820c43d417d768ade1f0f603e30a6c53b82fa1b82b3a8c95e5bc5eae4440c5bc77881022eceab2479b8aa4342d8fd07266897d679fe6422ff7152e SHA512 47d3d8a458ea1cf7a81092238534e4788c059a2450adb5db7b29b02ff4a0254bec4ced59534fdf481b03a5374fa12a5693fcf6cbba1eebeeee08361ced01a0e0
+DIST restic-0.17.0.tar.gz 24093378 BLAKE2B 9930c1b7e27b532cfefecfd5bc8f90112e75452c5fe660015b5c31493018914f4f81fc3895fa83045a099cfd600d1bc615e689ec0cda28ecb93f4b95c6a3b075 SHA512 f9b91844f8eec7b462af05bf210c489c440ef7e8d2a5109aed4c1ead5988d722c74ca84ba770270e65c683e1c973ed0d36a3a218f2170da936d84028a264938b
diff --git a/app-backup/restic/restic-0.17.0.ebuild b/app-backup/restic/restic-0.17.0.ebuild
new file mode 100644
index 000000000000..1f7370b91e27
--- /dev/null
+++ b/app-backup/restic/restic-0.17.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module shell-completion
+
+DESCRIPTION="A backup program that is fast, efficient and secure"
+HOMEPAGE="https://restic.github.io/"
+SRC_URI="https://github.com/restic/restic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://gentoo.kropotkin.rocks/go-pkgs/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 LGPL-3-with-linking-exception MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="sys-fs/fuse:0"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ local mygoargs=(
+ -tags release
+ -ldflags "-X main.version=${PV}"
+ -asmflags "-trimpath=${S}"
+ -gcflags "-trimpath=${S}"
+ )
+
+ ego build "${mygoargs[@]}" -o restic ./cmd/restic
+}
+
+src_test() {
+ addwrite /dev/fuse
+ # a number of the ./cmd/... tests fail
+ # ego test -timeout 30m ./cmd/... ./internal/...
+ RESTIC_TEST_FUSE=0 ego test -timeout 30m ./internal/...
+}
+
+src_install() {
+ dobin restic
+
+ newbashcomp doc/bash-completion.sh "${PN}"
+ newzshcomp doc/zsh-completion.zsh _restic
+ newfishcomp doc/fish-completion.fish "${PN}"
+
+ doman doc/man/*
+ dodoc doc/*.rst
+}