summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-03-07 19:33:02 +0530
committerZac Medico <zmedico@gentoo.org>2024-03-07 18:30:02 -0800
commit226ab6f84133747ca38fd5fcde1addd22adbeebd (patch)
tree04dabec356c7987f4213738c0a5b602c87f78cdb /app-containers
parentwww-client/chromium: add 123.0.6312.28 (diff)
downloadgentoo-226ab6f84133747ca38fd5fcde1addd22adbeebd.tar.gz
gentoo-226ab6f84133747ca38fd5fcde1addd22adbeebd.tar.bz2
gentoo-226ab6f84133747ca38fd5fcde1addd22adbeebd.zip
app-containers/buildah: add 1.35.0
1. Remove USE doc and install few KBs of docs unconditionally Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Closes: https://github.com/gentoo/gentoo/pull/35655 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/buildah/Manifest1
-rw-r--r--app-containers/buildah/buildah-1.35.0.ebuild122
-rw-r--r--app-containers/buildah/buildah-9999.ebuild7
3 files changed, 125 insertions, 5 deletions
diff --git a/app-containers/buildah/Manifest b/app-containers/buildah/Manifest
index 3bae66fc7635..ea1caa0133c6 100644
--- a/app-containers/buildah/Manifest
+++ b/app-containers/buildah/Manifest
@@ -2,3 +2,4 @@ DIST buildah-1.33.5.tar.gz 18579521 BLAKE2B a59bfda3dea1f588a2f77a26b942da6ae02a
DIST buildah-1.33.6.tar.gz 18585405 BLAKE2B 4a6f6ebfce7799a45b0984b6f9a319becfed87d5acf5f1f784249ff6e5397495ac72c00a22ff0bcc68fd94f1d0a591fa4ac5f0f88bcc9c0a6cdefe117166b4ec SHA512 86eab18af459b0b92361d6e9f56ebe9dab65527d829e7771c13b6c574ef45746a7f53520783ff52978b14aac0d6ee8de32cdabf807666a96dcf46e07e36157e2
DIST buildah-1.34.0.tar.gz 18751419 BLAKE2B 6584c5234e849f9b8cde5e4188791024c8ac5c0ba85859e289f3eb2ec32f97f722ebf25f1291f29e14edf4adc14e19d6a6a76630c820085e9f345736aeb3d4eb SHA512 a3836ce540058f418131969e157d548864727398535e4e99a693d883419b8d764da7166f9b9376c2b9686d8beac101687843c2e93198b16328ef333ad96d55db
DIST buildah-1.34.1.tar.gz 18838539 BLAKE2B de11f64a54fa24c8aa543dd44e6a3fca9df62eecf39541fa37c22a2dc64560d056f638a6b1f8aa564a09f0594a5e7150ef14fd9ab8cc61390dc6d7d8afa5545b SHA512 2d229ead1149b66d1b7d91f596809e97e5316356ab0997ea335eb3e246ed8bc6879e0e260bb478b4d7ec7c42c7dbf33d0e91086a34e89a3b79eb27322da06c1e
+DIST buildah-1.35.0.tar.gz 19353483 BLAKE2B 806c098d557480b6d6e92e6da61c32e48dfd6c1bfa4926a2871a8f41a3ef5f35d91381e51d33636a892bce930eabfda509e97e9efa60ba5c4feab75781d027ee SHA512 b4dd30b4d8087bbd0bbfd9a7b9791afc015a0c489041b38d6b6241df27a97286083dcf7b25102ce1fa1080265378442be73313e301c22660f21d8e4f39bb3aa4
diff --git a/app-containers/buildah/buildah-1.35.0.ebuild b/app-containers/buildah/buildah-1.35.0.ebuild
new file mode 100644
index 000000000000..8d0698568fd3
--- /dev/null
+++ b/app-containers/buildah/buildah-1.35.0.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module linux-info
+
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+
+# main pkg
+LICENSE="Apache-2.0"
+# deps
+LICENSE+=" BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+
+SLOT="0"
+IUSE="apparmor btrfs +seccomp systemd test"
+RESTRICT="test"
+DOCS=(
+ "CHANGELOG.md"
+ "troubleshooting.md"
+ "docs/tutorials"
+)
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/buildah.git"
+else
+ SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+RDEPEND="
+ systemd? ( sys-apps/systemd )
+ btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp:= )
+ apparmor? ( sys-libs/libapparmor:= )
+ app-containers/containers-common
+ app-crypt/gpgme:=
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-apps/shadow:=
+"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ local CONFIG_CHECK=""
+ use btrfs && CONFIG_CHECK+=" ~BTRFS_FS"
+ check_extra_config
+
+ linux_config_exists || ewarn "Cannot determine configuration of your kernel."
+}
+
+src_prepare() {
+ default
+
+ # ensure all necessary files are there
+ local file
+ for file in docs/Makefile hack/libsubid_tag.sh hack/apparmor_tag.sh \
+ hack/systemd_tag.sh btrfs_installed_tag.sh btrfs_tag.sh; do
+ [[ -f "${file}" ]] || die
+ done
+
+ sed -i -e "s|/usr/local|/usr|g" Makefile docs/Makefile || die
+ echo -e '#!/usr/bin/env bash\necho libsubid' > hack/libsubid_tag.sh || die
+
+ cat <<-EOF > hack/apparmor_tag.sh || die
+ #!/usr/bin/env bash
+ $(usex apparmor 'echo apparmor' echo)
+ EOF
+
+ use seccomp || {
+ cat <<-'EOF' > "${T}/disable_seccomp.patch"
+ --- a/Makefile
+ +++ b/Makefile
+ @@ -5 +5 @@
+ -SECURITYTAGS ?= seccomp $(APPARMORTAG)
+ +SECURITYTAGS ?= $(APPARMORTAG)
+ EOF
+ eapply "${T}/disable_seccomp.patch" || die
+ }
+
+ cat <<-EOF > hack/systemd_tag.sh || die
+ #!/usr/bin/env bash
+ $(usex systemd 'echo systemd' echo)
+ EOF
+
+ echo -e "#!/usr/bin/env bash\n echo" > btrfs_installed_tag.sh || die
+ cat <<-EOF > btrfs_tag.sh || die
+ #!/usr/bin/env bash
+ $(usex btrfs echo 'echo exclude_graphdriver_btrfs btrfs_noversion')
+ EOF
+
+ use test || {
+ cat <<-'EOF' > "${T}/disable_tests.patch"
+ --- a/Makefile
+ +++ b/Makefile
+ @@ -54 +54 @@
+ -all: bin/buildah bin/imgtype bin/copy bin/tutorial docs
+ +all: bin/buildah docs
+ EOF
+ eapply "${T}/disable_tests.patch" || die
+ }
+
+}
+
+src_compile() {
+ # For non-live versions, prevent git operations which causes sandbox violations
+ # https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
+ [[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT=""
+
+ default
+}
+
+src_test() {
+ emake test-unit
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install install.completions
+ einstalldocs
+}
diff --git a/app-containers/buildah/buildah-9999.ebuild b/app-containers/buildah/buildah-9999.ebuild
index d5fd4e7a796e..8d0698568fd3 100644
--- a/app-containers/buildah/buildah-9999.ebuild
+++ b/app-containers/buildah/buildah-9999.ebuild
@@ -14,12 +14,10 @@ LICENSE="Apache-2.0"
LICENSE+=" BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
SLOT="0"
-IUSE="apparmor btrfs +seccomp systemd doc test"
+IUSE="apparmor btrfs +seccomp systemd test"
RESTRICT="test"
-EXTRA_DOCS=(
+DOCS=(
"CHANGELOG.md"
- "CONTRIBUTING.md"
- "install.md"
"troubleshooting.md"
"docs/tutorials"
)
@@ -121,5 +119,4 @@ src_test() {
src_install() {
emake DESTDIR="${ED}" install install.completions
einstalldocs
- use doc && dodoc -r "${EXTRA_DOCS[@]}"
}