summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Günzler <r@gnzler.io>2024-08-07 17:54:07 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-08-20 09:37:35 +0300
commite100688fbf5a78a5271e483d892714b0e15cd4e1 (patch)
treeb11cec6e85b04082082ca070bbff4a40b32a6a16 /app-containers
parentapp-containers/crun: bump to 1.16 (diff)
downloadgentoo-e100688fbf5a78a5271e483d892714b0e15cd4e1.tar.gz
gentoo-e100688fbf5a78a5271e483d892714b0e15cd4e1.tar.bz2
gentoo-e100688fbf5a78a5271e483d892714b0e15cd4e1.zip
app-containers/crun: enable limited testing
Signed-off-by: Robert Günzler <r@gnzler.io> Closes: https://github.com/gentoo/gentoo/pull/38009 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/crun/crun-1.16.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/app-containers/crun/crun-1.16.ebuild b/app-containers/crun/crun-1.16.ebuild
index f7678e12c5e5..631d7a2535dd 100644
--- a/app-containers/crun/crun-1.16.ebuild
+++ b/app-containers/crun/crun-1.16.ebuild
@@ -37,11 +37,6 @@ BDEPEND="
virtual/pkgconfig
"
-# the crun test suite is comprehensive to the extent that tests will fail
-# within a sandbox environment, due to the nature of the privileges
-# required to create linux "containers".
-RESTRICT="test"
-
src_configure() {
local myeconfargs=(
$(use_enable bpf)
@@ -63,3 +58,18 @@ src_install() {
einfo "Cleaning up .la files"
find "${ED}" -name '*.la' -delete || die
}
+
+src_test() {
+ emake check-TESTS -C ./libocispec
+
+ # the crun test suite is comprehensive to the extent that tests will fail
+ # within a sandbox environment, due to the nature of the privileges
+ # required to create linux "containers".
+ local supported_tests=(
+ "tests/tests_libcrun_utils"
+ "tests/tests_libcrun_errors"
+ "tests/tests_libcrun_intelrdt"
+ "tests/test_oci_features"
+ )
+ emake check-TESTS TESTS="${supported_tests[*]}"
+}