summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-02-05 11:18:31 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-02-05 11:23:01 -0600
commit1784ecdb797d2664edfda060f162669546e27a40 (patch)
tree28726052e06ee1bd013b8b748df5aa012d10f8d4 /app-crypt/certbot-nginx/certbot-nginx-1.2.0.ebuild
parentapp-crypt/certbot-apache: 0.40.1 cleanup (diff)
downloadgentoo-1784ecdb797d2664edfda060f162669546e27a40.tar.gz
gentoo-1784ecdb797d2664edfda060f162669546e27a40.tar.bz2
gentoo-1784ecdb797d2664edfda060f162669546e27a40.zip
app-crypt/certbot-nginx: 1.2.0 bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-nginx/certbot-nginx-1.2.0.ebuild')
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-1.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/certbot-nginx-1.2.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-1.2.0.ebuild
new file mode 100644
index 000000000000..b87bdbf7b7dd
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-1.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=app-crypt/acme-1.0.0[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"