summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/gpgme
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/gpgme')
-rw-r--r--app-crypt/gpgme/Manifest1
-rw-r--r--app-crypt/gpgme/files/gpgme-1.1.8-et_EE.patch11
-rw-r--r--app-crypt/gpgme/gpgme-1.5.5.ebuild41
-rw-r--r--app-crypt/gpgme/metadata.xml8
4 files changed, 61 insertions, 0 deletions
diff --git a/app-crypt/gpgme/Manifest b/app-crypt/gpgme/Manifest
new file mode 100644
index 000000000000..0dd3131e6b8c
--- /dev/null
+++ b/app-crypt/gpgme/Manifest
@@ -0,0 +1 @@
+DIST gpgme-1.5.5.tar.bz2 976383 SHA256 0b3d3d5107680c594777aae65882a1ff6dd1ba629a83432e719c8b82a743c207 SHA512 a01b84c1ae2a7c647b2de793fc05d39c4bf4a2d1b7378934e437857823f11ca9e9c1f3b32302d69a3a84d0be1fee1e1c86874355031b8fa6b40f4ad56ecc72ad WHIRLPOOL f3ad4282a254cf1ab8d01184df787a773fa7963a42157da93bee11430263fa86166f12f051e2b11d13be99ce1f0939d565cb02a8fba93ab6afed73ca7b2c0041
diff --git a/app-crypt/gpgme/files/gpgme-1.1.8-et_EE.patch b/app-crypt/gpgme/files/gpgme-1.1.8-et_EE.patch
new file mode 100644
index 000000000000..dc921eec4056
--- /dev/null
+++ b/app-crypt/gpgme/files/gpgme-1.1.8-et_EE.patch
@@ -0,0 +1,11 @@
+--- ./gpgme-1.1.8/src/gpgme-config.in.orig 2009-03-08 10:25:48.000000000 +1100
++++ ./gpgme-1.1.8/src/gpgme-config.in 2009-03-08 10:35:53.000000000 +1100
+@@ -64,7 +64,7 @@
+ while test $# -gt 0; do
+ case "$1" in
+ -*=*)
+- optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'`
++ optarg=`echo "$1" | sed 's/[-_[:alnum:]]*=//'`
+ ;;
+ *)
+ optarg=
diff --git a/app-crypt/gpgme/gpgme-1.5.5.ebuild b/app-crypt/gpgme/gpgme-1.5.5.ebuild
new file mode 100644
index 000000000000..a821649bb462
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-1.5.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils libtool
+
+DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
+HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
+SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="1/11" # subslot = soname major version
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="common-lisp static-libs"
+
+DEPEND="app-crypt/gnupg
+ >=dev-libs/libassuan-2.0.2
+ >=dev-libs/libgpg-error-1.11"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.8-et_EE.patch
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --includedir="${EPREFIX}/usr/include/gpgme" \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ if ! use common-lisp; then
+ rm -fr "${ED}usr/share/common-lisp"
+ fi
+}
diff --git a/app-crypt/gpgme/metadata.xml b/app-crypt/gpgme/metadata.xml
new file mode 100644
index 000000000000..780611be23d4
--- /dev/null
+++ b/app-crypt/gpgme/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <use>
+ <flag name="common-lisp">Install common-lisp files</flag>
+ </use>
+</pkgmetadata>