summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-07 22:34:55 +0100
committerSam James <sam@gentoo.org>2023-07-07 23:04:14 +0100
commita9afd84bae632bd30d284b04f6aa1f03b11f67f1 (patch)
tree4044ea3dd3947532360bc361c9ce0f47ee1ab142 /app-crypt/gpgme
parentsys-devel/gcc: drop 10.4.1_p20230517, 10.4.1_p20230628 (diff)
downloadgentoo-a9afd84bae632bd30d284b04f6aa1f03b11f67f1.tar.gz
gentoo-a9afd84bae632bd30d284b04f6aa1f03b11f67f1.tar.bz2
gentoo-a9afd84bae632bd30d284b04f6aa1f03b11f67f1.zip
app-crypt/gpgme: add 1.21.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/gpgme')
-rw-r--r--app-crypt/gpgme/Manifest2
-rw-r--r--app-crypt/gpgme/gpgme-1.21.0.ebuild163
2 files changed, 165 insertions, 0 deletions
diff --git a/app-crypt/gpgme/Manifest b/app-crypt/gpgme/Manifest
index 340e3430f548..972170215581 100644
--- a/app-crypt/gpgme/Manifest
+++ b/app-crypt/gpgme/Manifest
@@ -1,2 +1,4 @@
DIST gpgme-1.20.0.tar.bz2 1817377 BLAKE2B 1dce0f32a29ece87f9e0f5c9da394fe3e3b651344889f36e7c403a8336e53f831425384cc43b5aeebc96da50b5ac139a8f5b07dad85e341dcbc4b47b35c8e77a SHA512 82dfd272edd4adab09e8428bf809c13eeb50a4a7d2397c41d29ffa3832c4f46054ad75eb053fbcc876ebbf78bb8bcf71d95bc9dad68f4b326492ea513dd5b606
DIST gpgme-1.20.0.tar.bz2.sig 119 BLAKE2B 2f623dae9bbfa68eab7433854b4357dbcb1412488cc347d9088b3da762f656467de6a57a9658e28789c2dfddbf8032aa7683c103e4daa4fdc35502a37c3efc3b SHA512 7c4632aa7c3b31653046ede11afd49eef9986675196c64e2078d65f9fb732898a6f3e818de89f51056eaff5a4854e1f859151a90f1e124890d21219f8c30b3fa
+DIST gpgme-1.21.0.tar.bz2 1830113 BLAKE2B 77000567fde5b78bf46352b25c81e7223506c00703360c87d3bd05afde29ef33d7f9f82e2dbe20f4e64bb6d99a0d8f442d88762d14a72b7ddabf5b38be62e130 SHA512 eb70813d22920d6d54459a4271259edf55d5833edfdd053551ca245521e06a8c19ed02dc93e0c53132a699e6d8c82499f50caf8e390af28468e3549470595b7d
+DIST gpgme-1.21.0.tar.bz2.sig 119 BLAKE2B ac19a5694e139be36ee9c6e28501d4a695166cfbc8f1561de7c7741a274f35cb0a67f779b5fc1ff58b5a11eeaa5e575c06233be65d01c40504efe16a759740ea SHA512 8a471333fd0fc6da50990c3aed67900a6b183cde0fcc449d37435289d8f309c68555c741281c06af9740ac088ae0b4747263da1dfd23d90b050185706948b227
diff --git a/app-crypt/gpgme/gpgme-1.21.0.ebuild b/app-crypt/gpgme/gpgme-1.21.0.ebuild
new file mode 100644
index 000000000000..f1f283dbfa22
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-1.21.0.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Maintainers should:
+# 1. Join the "Gentoo" project at https://dev.gnupg.org/project/view/27/
+# 2. Subscribe to release tasks like https://dev.gnupg.org/T6159
+# (find the one for the current release then subscribe to it +
+# any subsequent ones linked within so you're covered for a while.)
+
+DISTUTILS_EXT=1
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python3_{10..12} )
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/gnupg.asc
+
+inherit distutils-r1 libtool flag-o-matic qmake-utils toolchain-funcs verify-sig
+
+DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
+HOMEPAGE="https://www.gnupg.org/related_software/gpgme"
+SRC_URI="
+ mirror://gnupg/gpgme/${P}.tar.bz2
+ verify-sig? ( mirror://gnupg/gpgme/${P}.tar.bz2.sig )
+"
+
+LICENSE="GPL-2 LGPL-2.1"
+# Please check ABI on each bump, even if SONAMEs didn't change: bug #833355
+# Use e.g. app-portage/iwdevtools integration with dev-libs/libabigail's abidiff.
+# Subslot: SONAME of each: <libgpgme.libgpgmepp.libqgpgme.FUDGE>
+# Bump FUDGE if a release is made which breaks ABI without changing SONAME.
+# (Reset to 0 if FUDGE != 0 if libgpgme/libgpgmepp/libqpggme change.)
+SLOT="1/11.6.15.2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="common-lisp static-libs +cxx python qt5 test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="qt5? ( cxx ) python? ( ${PYTHON_REQUIRED_USE} )"
+
+# - On each bump, update dep bounds on each version from configure.ac!
+RDEPEND="
+ >=app-crypt/gnupg-2
+ >=dev-libs/libassuan-2.5.3:=
+ >=dev-libs/libgpg-error-1.36:=
+ >=dev-libs/libgpg-error-1.46-r1
+ python? ( ${PYTHON_DEPS} )
+ qt5? ( dev-qt/qtcore:5 )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ qt5? ( dev-qt/qttest:5 )
+ )
+"
+#doc? ( app-doc/doxygen[dot] )
+BDEPEND="
+ python? ( dev-lang/swig )
+ verify-sig? ( sec-keys/openpgp-keys-gnupg )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.18.0-tests-start-stop-agent-use-command-v.patch
+)
+
+src_prepare() {
+ default
+
+ elibtoolize
+
+ # bug #697456
+ addpredict /run/user/$(id -u)/gnupg
+
+ local MAX_WORKDIR=66
+ if use test && [[ "${#WORKDIR}" -gt "${MAX_WORKDIR}" ]]; then
+ eerror "Unable to run tests as WORKDIR='${WORKDIR}' is longer than ${MAX_WORKDIR} which causes failure!"
+ die "Could not run tests as requested with too-long WORKDIR."
+ fi
+
+ # Make best effort to allow longer PORTAGE_TMPDIR
+ # as usock limitation fails build/tests
+ ln -s "${P}" "${WORKDIR}/b" || die
+ S="${WORKDIR}/b"
+}
+
+src_configure() {
+ local languages=()
+
+ # bug #847955
+ append-lfs-flags
+
+ if use common-lisp ; then
+ languages+=( "cl" )
+ fi
+
+ if use cxx ; then
+ languages+=( "cpp" )
+ fi
+
+ # TODO: qt6? but qt5 and qt5 are mutually exclusive :(
+ if use qt5; then
+ languages+=( "qt5" )
+
+ #use doc ||
+ export DOXYGEN=true
+ export MOC="$(qt5_get_bindir)/moc"
+ fi
+
+ local myeconfargs=(
+ $(use test || echo "--disable-gpgconf-test --disable-gpg-test --disable-gpgsm-test --disable-g13-test")
+ --enable-languages="${languages[*]}"
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+
+ if use python ; then
+ emake -C lang/python prepare
+
+ pushd lang/python > /dev/null || die
+ top_builddir="../.." srcdir="." CPP="$(tc-getCPP)" distutils-r1_src_configure
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ default
+
+ if use python ; then
+ pushd lang/python > /dev/null || die
+ top_builddir="../.." srcdir="." CPP="$(tc-getCPP)" distutils-r1_src_compile
+ popd > /dev/null || die
+ fi
+}
+
+src_test() {
+ default
+
+ if use python ; then
+ distutils-r1_src_test
+ fi
+}
+
+python_test() {
+ emake -C lang/python/tests check \
+ PYTHON=${EPYTHON} \
+ PYTHONS=${EPYTHON} \
+ TESTFLAGS="--python-libdir=${BUILD_DIR}/lib"
+}
+
+src_install() {
+ default
+
+ if use python ; then
+ pushd lang/python > /dev/null || die
+ top_builddir="../.." srcdir="." CPP="$(tc-getCPP)" distutils-r1_src_install
+ popd > /dev/null || die
+ fi
+
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ # Backward compatibility for gentoo
+ # (in the past, we had slots)
+ dodir /usr/include/gpgme
+ dosym ../gpgme.h /usr/include/gpgme/gpgme.h
+}