summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-12-23 21:16:18 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-12-23 21:16:18 +0100
commit77f2662e2d5507fdf1fb487c0a5fcdee834dde66 (patch)
tree50bfa2c8845f557e28be2845827268d609ca6140 /app-crypt/ssss/ssss-0.5.7-r3.ebuild
parentnet-libs/libupnp: drop 1.14.19 (diff)
downloadgentoo-77f2662e2d5507fdf1fb487c0a5fcdee834dde66.tar.gz
gentoo-77f2662e2d5507fdf1fb487c0a5fcdee834dde66.tar.bz2
gentoo-77f2662e2d5507fdf1fb487c0a5fcdee834dde66.zip
app-crypt/ssss: replace 'type -P' by 'command -v'
Closes: https://bugs.gentoo.org/940450 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-crypt/ssss/ssss-0.5.7-r3.ebuild')
-rw-r--r--app-crypt/ssss/ssss-0.5.7-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-crypt/ssss/ssss-0.5.7-r3.ebuild b/app-crypt/ssss/ssss-0.5.7-r3.ebuild
new file mode 100644
index 000000000000..07d5ef24f93b
--- /dev/null
+++ b/app-crypt/ssss/ssss-0.5.7-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Shamir's Secret Sharing Scheme"
+HOMEPAGE="https://github.com/MrJoy/ssss"
+SRC_URI="https://github.com/MrJoy/${PN}/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-releases-v${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-libs/gmp:0="
+DEPEND="${RDEPEND}"
+BDEPEND="app-text/xmltoman"
+
+HTML_DOCS=( "doc.html" "ssss.1.html" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+
+ # Respect users [CL]FLAGS
+ # Don't strip, as portage does this part
+ # Don't use 'which'
+ sed -e 's/-O2/$(CFLAGS) -lgmp $(LDFLAGS)/g' -e '/strip/d' -e 's/which/command -v/g' -i Makefile || die
+}
+
+src_install() {
+ dobin ssss-split
+ dosym ssss-split /usr/bin/ssss-combine
+
+ doman ssss.1
+
+ einstalldocs
+}