summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2016-11-24 09:46:26 +0100
committerUlrich Müller <ulm@gentoo.org>2016-11-24 09:46:26 +0100
commit11b9e5b1ff3925198dff61c48282e8993b418ad1 (patch)
tree3d2475839ff793027b06f15be3f29b53aecfebd1 /app-doc
parentnet-im/pyicq-t: Allow monolithic twisted to satisfy dependencies (diff)
downloadgentoo-11b9e5b1ff3925198dff61c48282e8993b418ad1.tar.gz
gentoo-11b9e5b1ff3925198dff61c48282e8993b418ad1.tar.bz2
gentoo-11b9e5b1ff3925198dff61c48282e8993b418ad1.zip
app-doc/casting-spels-emacs: Bump to EAPI 6. Update HOMEPAGE.
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/casting-spels-emacs/casting-spels-emacs-19-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-doc/casting-spels-emacs/casting-spels-emacs-19-r2.ebuild b/app-doc/casting-spels-emacs/casting-spels-emacs-19-r2.ebuild
new file mode 100644
index 000000000000..9f63d93ee9bd
--- /dev/null
+++ b/app-doc/casting-spels-emacs/casting-spels-emacs-19-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp-common
+
+DESCRIPTION="Casting SPELs in Lisp - A Comic Book (Emacs Lisp Edition)"
+HOMEPAGE="http://www.lisperati.com/casting-spels-emacs/html/casting-spels-emacs-1.html
+ https://www.gnu.org/software/emacs/casting-spels-emacs/"
+SRC_URI="https://casting-spels-emacs.googlecode.com/files/${PN}-v${PV}.zip"
+
+LICENSE="GPL-2+ FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/emacs"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i 's/\r$//' *.txt html/*.html {lisp,test}/*.el || die
+ # needs cl extensions
+ eapply "${FILESDIR}/${P}-require-cl.patch"
+ eapply_user
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.el
+ dodoc README.txt test/walk-through-commands.el
+ docinto html
+ dodoc html/*.html
+ docinto html/images
+ dodoc images/*.jpg images/*.png
+ dosym html/images /usr/share/doc/${PF}/images
+ dosym ${SITELISP}/${PN} /usr/share/doc/${PF}/lisp
+}