summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James (sam_c) <sam@cmpct.info>2020-06-05 14:35:15 +0000
committerMart Raudsepp <leio@gentoo.org>2020-06-05 18:44:57 +0300
commit064d1ba223830dc08ec8c43797e012577ae22439 (patch)
tree0ba6823d2f1dd07870d6baa9db12469f48e3b0c8 /app-editors/kakoune
parentdev-util/trace-cmd: arm64 keyworded (bug #726704) (diff)
downloadgentoo-064d1ba223830dc08ec8c43797e012577ae22439.tar.gz
gentoo-064d1ba223830dc08ec8c43797e012577ae22439.tar.bz2
gentoo-064d1ba223830dc08ec8c43797e012577ae22439.zip
app-editors/kakoune: Drop static-libs
Closes: https://bugs.gentoo.org/727236 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-editors/kakoune')
-rw-r--r--app-editors/kakoune/kakoune-2020.01.16-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-editors/kakoune/kakoune-2020.01.16-r1.ebuild b/app-editors/kakoune/kakoune-2020.01.16-r1.ebuild
new file mode 100644
index 000000000000..561d502005c2
--- /dev/null
+++ b/app-editors/kakoune/kakoune-2020.01.16-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Modal editor inspired by vim"
+HOMEPAGE="http://kakoune.org/ https://github.com/mawww/kakoune"
+SRC_URI="https://github.com/mawww/kakoune/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+
+DEPEND="sys-libs/ncurses:0=[unicode]"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/kakoune-2020.01.16-enable-ebuild-syntax-highlight.patch )
+
+src_configure() { :; }
+
+src_compile() {
+ cd src/ || die
+
+ emake all
+}
+
+src_test() {
+ cd src/ || die
+ emake test
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr docdir="${D}/usr/share/doc/${PF}" install
+
+ rm "${D}/usr/share/man/man1/kak.1.gz" || die
+ doman doc/kak.1
+}