summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2024-01-16 11:57:19 +0530
committerSam James <sam@gentoo.org>2024-01-16 06:38:01 +0000
commitb603c4da67de50aca62559471bf59b72f9f4059d (patch)
tree66b444503c200da1c6c02ccc84b52777657a2a1c /app-editors/neovim
parentdev-python/scipy: filter LTO since it is unsafe (diff)
downloadgentoo-b603c4da67de50aca62559471bf59b72f9f4059d.tar.gz
gentoo-b603c4da67de50aca62559471bf59b72f9f4059d.tar.bz2
gentoo-b603c4da67de50aca62559471bf59b72f9f4059d.zip
app-editors/neovim: fix finding luajit in live
Commit 7b054106ef5a1fd742fb23886173d8c5a842d715 was lost with commit beea6ed74eb77f3f16cb60e441cf51afd08ccc71, thus introducing bug 922138. Closes: https://bugs.gentoo.org/922138 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34833 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/neovim')
-rw-r--r--app-editors/neovim/neovim-9999.ebuild1
1 files changed, 1 insertions, 0 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 1aa5eaa0db8b..c24b0952e017 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -81,6 +81,7 @@ src_prepare() {
}
src_configure() {
+ ln -s "${BROOT}"/usr/bin/luajit "${BUILD_DIR}"/luajit || die
# TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
local mycmakeargs=(
# appends -flto