summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2021-11-06 13:44:29 +0100
committerSam James <sam@gentoo.org>2021-11-07 04:15:07 +0000
commit23bb307ead139ddd0b0044060926199474cdba7d (patch)
treef01d75257a591b3dcc3f290e6146ce31b9330bce /app-editors
parentapp-editors/vscode: remove old version (diff)
downloadgentoo-23bb307ead139ddd0b0044060926199474cdba7d.tar.gz
gentoo-23bb307ead139ddd0b0044060926199474cdba7d.tar.bz2
gentoo-23bb307ead139ddd0b0044060926199474cdba7d.zip
app-editors/vscodium: version bump to 1.62.0
Bug: https://bugs.gentoo.org/822135 Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com> Closes: https://github.com/gentoo/gentoo/pull/22841 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.62.0.ebuild113
2 files changed, 116 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index c4fb9a15a3db..6281621b3d4c 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -7,3 +7,6 @@ DIST vscodium-1.60.2-arm64.tar.gz 111897534 BLAKE2B cf5ae8cd8e98342b0eccbf2fb138
DIST vscodium-1.61.2-amd64.tar.gz 114016604 BLAKE2B b9006b0a58adc08df31bbae08a46c233cd69ee80f89493e4564f8f3dbe595481582cb605ff472984f013e364bdafbdd2f587ea3d0065d8ca775eb723f0cd4cb0 SHA512 4a1016bc8e9fea5c76a0c87180ad641f4ec981dbde0b395267580d5207cf181a090d87e984a96c40f46298cbf8185c1afe4af6a8791bc47126f50f1ba95edacc
DIST vscodium-1.61.2-arm.tar.gz 97521784 BLAKE2B c81f5b607905d3be0aa27ee63a49c0ba2225724686d1afc25f7c15289c69fd10022d1ae83390183bd50c1db9c0b74e3c9144e622e81f2895eb891d6800d1bfd2 SHA512 f4f329155282e951273580247e3262b887164f2bedf409700f3a8326e9dd2e20ab95ab4b5fe8dbf2a177487e518c9fe98078a485c08b020b4d73cc7cb9a90431
DIST vscodium-1.61.2-arm64.tar.gz 112085871 BLAKE2B 47c58659d6e4e9a468b014c9d0a8f6ca9739d722a21ec0b3add0a69849b18022dafdcadc759070e054492d6cf2db1bf07e11454fee5623647a54e367f5d94325 SHA512 cf893f6e04a0e657fb889b40069e042ad1b2a287a349c3f05e441ada00504f9ec693f20dfe17a01f6a7d2d298dbecfe94d62f12b8b26769e373f61ae9ffda8f7
+DIST vscodium-1.62.0-amd64.tar.gz 114309026 BLAKE2B 7a01584d512ce437b162cedd1113c769893dfc1a4e9827e69d6ff383c691328e4c24755261c509ce46c459ec65d7e61874270eaed1fe485e6d12d7d65c3b34e1 SHA512 65890d9b4c57555d58040012d52a8acc242a583e064f7562ac0e13ed01b5f50213974c06e26c3fc7a9fc68914cd25093ec69ad24d7d1c4d2f9cf2b3310cb7bed
+DIST vscodium-1.62.0-arm.tar.gz 97824588 BLAKE2B 2afecab90d000fbd635dfec667472074ab82981464236aa1d857927f0681515759472d19fc3c9eb35ba0d7d1ae16ff37e5cb4d9e57f2cbb3ca4bf0ae34654f1b SHA512 9cfc20c64c570c1ace9563b5f5750fd72aa122f60ec35404b3d3c49634dc6ff033ebe6e85bdc335c7740e3c77042aad1bfdd6d8387e1a7554f3f8c8392998db0
+DIST vscodium-1.62.0-arm64.tar.gz 112396932 BLAKE2B 4f8580eefad8974cce597e002a70c93af46370b5e33fb617b0f87bf34da997805d7da73e0d6528d7871e1cffd914fad967b731a3c64dffbb07cc92b9c415eb5a SHA512 4978d9c013b11fd234c597e43db0b2a1dcb7aa97c0d1f88994245ce2e4d82fb5d5a5bb91320826baed5d8b81e938ca79d43824b4deb0ef0e82a6cc7b462b76b7
diff --git a/app-editors/vscodium/vscodium-1.62.0.ebuild b/app-editors/vscodium/vscodium-1.62.0.ebuild
new file mode 100644
index 000000000000..1f66143c0bf3
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.62.0.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop pax-utils xdg
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-armhf-${PV}.tar.gz -> ${P}-arm.tar.gz )
+ arm64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-arm64-${PV}.tar.gz -> ${P}-arm64.tar.gz )
+"
+
+RESTRICT="mirror strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-accessibility/at-spi2-core:2
+ app-crypt/libsecret[crypt]
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Install
+ pax-mark m codium
+ insinto "/opt/${PN}"
+ doins -r *
+ fperms +x /opt/${PN}/{,bin/}codium
+ fperms 4711 /opt/${PN}/chrome-sandbox
+ fperms 755 /opt/${PN}/resources/app/extensions/git/dist/askpass.sh
+ fperms 755 /opt/${PN}/resources/app/extensions/git/dist/askpass-empty.sh
+ fperms -R +x /opt/${PN}/resources/app/out/vs/base/node
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/vscode-ripgrep/bin/rg
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/codium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+}