summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-07-01 21:02:44 -0300
committerMatt Turner <mattst88@gentoo.org>2023-07-18 18:37:44 -0400
commit828a255921fa055537de34bc438ec2ffb110f366 (patch)
tree9e2af41df1d819c2020cce3dc586ddbe847da9cb /app-editors
parentdev-libs/libdex: Version bump to 0.3.0 (diff)
downloadgentoo-828a255921fa055537de34bc438ec2ffb110f366.tar.gz
gentoo-828a255921fa055537de34bc438ec2ffb110f366.tar.bz2
gentoo-828a255921fa055537de34bc438ec2ffb110f366.zip
app-editors/gnome-text-editor: Version bump to 45_alpha
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31701 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gnome-text-editor/Manifest1
-rw-r--r--app-editors/gnome-text-editor/gnome-text-editor-45_alpha.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-editors/gnome-text-editor/Manifest b/app-editors/gnome-text-editor/Manifest
index c20a629f81d4..28f2b6de87fe 100644
--- a/app-editors/gnome-text-editor/Manifest
+++ b/app-editors/gnome-text-editor/Manifest
@@ -1 +1,2 @@
DIST gnome-text-editor-44.0.tar.xz 610996 BLAKE2B 02ab81055402df584a448d0e611b608e5fa10d6f4a600755cbab9f730aa1806268f7277dafb4fd3aa95ff2be64d2894806c6038ad81dae7cfb87b28dccc7da24 SHA512 bca373a124c3e648fa28da1a493163d768488fa3645fcfbfa7a115e195c0c971dc98e007c9c0fdf7fe415df64e76071fc83e33831707bb31154e66355948bbb3
+DIST gnome-text-editor-45.alpha.tar.xz 605412 BLAKE2B fc8504e85a40bae866576325e5599ed274cc14bf9ac4391538419ca5afcd8bf51302948079f4bc52da16422ed46a13e93fe4d4f11f56d79f729c65847b175dcc SHA512 a4ba779a8454f13079a9e653272ed7aabca0df574acb22fd5271614f72569006186bd965db90a03c14a751fb15a2bb52a04b6d3338c487e0fcae5a26d88bbeba
diff --git a/app-editors/gnome-text-editor/gnome-text-editor-45_alpha.ebuild b/app-editors/gnome-text-editor/gnome-text-editor-45_alpha.ebuild
new file mode 100644
index 000000000000..cd243ed2cd77
--- /dev/null
+++ b/app-editors/gnome-text-editor/gnome-text-editor-45_alpha.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A simple text editor for the GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-text-editor"
+S="${WORKDIR}/gnome-text-editor-${PV/_/.}"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="spell"
+
+KEYWORDS="~amd64 ~riscv"
+
+DEPEND="
+ >=dev-libs/glib-2.73.0:2
+ >=gui-libs/gtk-4.7:4
+ >=gui-libs/gtksourceview-5.5.0:5
+ >=gui-libs/libadwaita-1.4_alpha:1
+ app-text/editorconfig-core-c
+ x11-libs/cairo
+ spell? (
+ >=app-text/enchant-2.2.0:2
+ dev-libs/icu:=
+ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.21
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature spell enchant)
+ -Dbugreport_url="https://bugs.gentoo.org"
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}