summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-04 09:24:38 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-04 09:43:28 +0100
commit4669736c247a03b49b1f888a4dac87e2ce36e65c (patch)
tree78a406002a5c3d9055ac5bae33d478a2d04ce5bb /app-emacs/emms/emms-17.ebuild
parentapp-emacs/emms: drop old 15 (diff)
downloadgentoo-4669736c247a03b49b1f888a4dac87e2ce36e65c.tar.gz
gentoo-4669736c247a03b49b1f888a4dac87e2ce36e65c.tar.bz2
gentoo-4669736c247a03b49b1f888a4dac87e2ce36e65c.zip
app-emacs/emms: bump to 17
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/emms/emms-17.ebuild')
-rw-r--r--app-emacs/emms/emms-17.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/emms/emms-17.ebuild b/app-emacs/emms/emms-17.ebuild
new file mode 100644
index 000000000000..c5130396d32c
--- /dev/null
+++ b/app-emacs/emms/emms-17.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="The Emacs Multimedia System"
+HOMEPAGE="https://www.gnu.org/software/emms/
+ https://www.emacswiki.org/emacs/EMMS"
+SRC_URI="https://git.savannah.gnu.org/cgit/emms.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="media-libs/taglib"
+BDEPEND="${RDEPEND}"
+
+# EMMS can use almost anything for playing media files therefore the dependency
+# possibilities are so broad that we refrain from setting anything explicitly
+# in DEPEND/RDEPEND.
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" all emms-print-metadata
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ exeinto /usr/bin
+ doexe src/emms-print-metadata
+
+ doinfo doc/emms.info*
+ doman emms-print-metadata.1
+
+ einstalldocs
+}