summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2023-03-19 08:41:41 +0000
committerMatthew Smith <matthew@gentoo.org>2023-03-19 08:41:41 +0000
commit4f99e857b0542305a1c85f47359c99f0a289b63d (patch)
tree0224ca06c61ebe12bce861a6cab6550fbd656a20 /app-emacs/vertico
parentprofiles/package.mask: mask obsolete dev-ruby/elasticsearch slot (diff)
downloadgentoo-4f99e857b0542305a1c85f47359c99f0a289b63d.tar.gz
gentoo-4f99e857b0542305a1c85f47359c99f0a289b63d.tar.bz2
gentoo-4f99e857b0542305a1c85f47359c99f0a289b63d.zip
app-emacs/vertico: add 1.2
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'app-emacs/vertico')
-rw-r--r--app-emacs/vertico/Manifest1
-rw-r--r--app-emacs/vertico/vertico-1.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/vertico/Manifest b/app-emacs/vertico/Manifest
index 6ea0b13224d4..92d87bd9d3e0 100644
--- a/app-emacs/vertico/Manifest
+++ b/app-emacs/vertico/Manifest
@@ -1,3 +1,4 @@
DIST vertico-0.29.tar.gz 43682 BLAKE2B fef1ae786c823d7180f1c2d312a5961309d934145029933cc05e09839120bb2f4fcd1dbfad2194bb8613badb49966d1f69eb658397e4e2346ccc46fb228136ff SHA512 6af726ee916090247d003f552470dea6a2348c3ca382e030fe4c3de777c3414ed00a50aa5cdec17de7e59ebd44f5d88d842a284b38be7f9edca9220a1b240da0
DIST vertico-1.0.tar.gz 43930 BLAKE2B 7418566d03c86c95aeb1969db19359628f04930413b17aaa2113836ee90368bb6df26c6af16a530a2977f3834b56565bbcd304ce362b6387baf9cc812c8b2982 SHA512 ad4e92b1edc5897f37b5ecc0c2f3291cf775afca14a33f1db17878f0560a4a1230513b833b1222f97b92f8711d2178bc30c6ccb55c8d22593f29b01717fd8968
DIST vertico-1.1.tar.gz 44320 BLAKE2B ca423d0a745cb0ed9c7f857f07595614264c8cf60056b696c31e26f85578278b1993c803556609fd444a1729f5380e314b39bd586073a6145b6b3e7f46462999 SHA512 e8df93ad4bd97d6313eefc3c2d88652841858a22db9be17b07e68095c158daf228f717524a6ba912541ce405afdfe5f696a3e5adf5d08c5e9e8b44694eb62294
+DIST vertico-1.2.tar.gz 44501 BLAKE2B 46ff938c13b6dbdf3f952a887b5fe4d091dfe68da067620e3ca2c567c783af748ab921502b7f5f66cfd6ffa7457b10563e95ae5d7add32565a15643531f83da4 SHA512 f7deeeaeb4b78a857e354dab8d61b5062147be4fb7b87083b0fd16d88bf26ec7354df462d17f756f538b32fbcbbda0878ee48540d1e45c592a5f7c2533c10eb0
diff --git a/app-emacs/vertico/vertico-1.2.ebuild b/app-emacs/vertico/vertico-1.2.ebuild
new file mode 100644
index 000000000000..0ff52c845500
--- /dev/null
+++ b/app-emacs/vertico/vertico-1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Vertical interactive completion"
+HOMEPAGE="https://github.com/minad/vertico"
+SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+BDEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.org README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el ./ || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}