summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-20 13:02:34 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-20 13:29:20 +0200
commit11f869c5684959f1c9b1d746f4a11ae3128bc1f0 (patch)
treea0d76df1000245256512107e9731c9738a47893c /app-emacs
parentapp-admin/rsyslog: patch cleanup (diff)
downloadgentoo-11f869c5684959f1c9b1d746f4a11ae3128bc1f0.tar.gz
gentoo-11f869c5684959f1c9b1d746f4a11ae3128bc1f0.tar.bz2
gentoo-11f869c5684959f1c9b1d746f4a11ae3128bc1f0.zip
app-emacs/helm: bump to 3.9.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/helm/Manifest1
-rw-r--r--app-emacs/helm/helm-3.9.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/helm/Manifest b/app-emacs/helm/Manifest
index 9d90a8edb85d..0b8777510214 100644
--- a/app-emacs/helm/Manifest
+++ b/app-emacs/helm/Manifest
@@ -1,2 +1,3 @@
DIST helm-3.9.1.tar.gz 2370645 BLAKE2B 819f0bf8cbd3728a78e90da6955f799a8ad2320323a9a16eb72a4fcfe21c04995f0fd0072a7a8bf6fcf593dedc4c3b224f0310ec317b9e39f326b4c147343b1b SHA512 7cd5d93493a08ec173b6786ec4e0cbaf3a90473f7ef8f7564232cedc438ed01466faeb8aced07419aedadd1469c8c43fe6072ee725643e133ceb3004675dc3b7
DIST helm-3.9.3.tar.gz 2373295 BLAKE2B ff34d5a68a1e25571c734185a37843d958b859096c22ca0222b64fb684a6de607d11b08f7beaa618f0017126c744f7f12dfe9d3ea03757874e485f4bdb5c2fc8 SHA512 4c1cce5eb93f89f388fb5da6a813f819867db6bc965ca378a788eaa5bf17c577b20034be9df57691737662d34809da4d86532b8b98765d6f102f84ee2169e80b
+DIST helm-3.9.4.tar.gz 2372828 BLAKE2B a1ca18531dcb1887d5a12b3536b05d68d6d40c7a41b9d3bd25f3cd286ccbd217bc45843007e208e84eafd5e3b4106d32461df87dd57d1a78d0a89f58cf933730 SHA512 17d5a99ea85481f7d4b9bea9fff2a602b0a824ad4f050b26e0225ec8e18025e6307434d4de31120786d3498f937a854ef4a080103df025be6a0e4718e7dd9161
diff --git a/app-emacs/helm/helm-3.9.4.ebuild b/app-emacs/helm/helm-3.9.4.ebuild
new file mode 100644
index 000000000000..76671b3b26bc
--- /dev/null
+++ b/app-emacs/helm/helm-3.9.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/
+ https://github.com/emacs-helm/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-emacs/async
+ app-emacs/popup
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.8.8-no-autoload-check.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ exeinto /usr/bin/
+ doexe emacs-helm.sh
+}