summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-11-19 21:58:28 +0100
committerUlrich Müller <ulm@gentoo.org>2017-11-19 22:20:58 +0100
commit7dd6db87fd16984363439550371b5feca7870ad4 (patch)
tree487f76120abd9e5bdb445de658fdd9546c131d06 /app-emacs
parentsys-libs/binutils-libs: stable 2.29.1-r1 for ppc, bug #627166 (diff)
downloadgentoo-7dd6db87fd16984363439550371b5feca7870ad4.tar.gz
gentoo-7dd6db87fd16984363439550371b5feca7870ad4.tar.bz2
gentoo-7dd6db87fd16984363439550371b5feca7870ad4.zip
app-emacs/websocket: Initial import.
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/websocket/Manifest1
-rw-r--r--app-emacs/websocket/metadata.xml8
-rw-r--r--app-emacs/websocket/websocket-1.9.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/websocket/Manifest b/app-emacs/websocket/Manifest
new file mode 100644
index 000000000000..287b2c761ffe
--- /dev/null
+++ b/app-emacs/websocket/Manifest
@@ -0,0 +1 @@
+DIST websocket-1.9.tar.gz 27029 SHA256 e7afbb5785e423e108119c9e625c9bab08297415224b07718f75ec6295130533 SHA512 bcd98e7edcbe95cae2f196cea05fd6cfa9083ed1ab2392530ca00cb05b87d6fa95b5f5319981fd94244b74989850c171e4c31c8758a8b7fe95d49299103a4410 WHIRLPOOL b0534b8c098569cebdf9ff597a459df7815f0e0a919c64fbbf4d8c64aa9789f0bbd585ca8adb139bb35254f29798e01e13eb417764a8bc0b1fbd20fa7ff564f7
diff --git a/app-emacs/websocket/metadata.xml b/app-emacs/websocket/metadata.xml
new file mode 100644
index 000000000000..c438baf3b326
--- /dev/null
+++ b/app-emacs/websocket/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-emacs/websocket/websocket-1.9.ebuild b/app-emacs/websocket/websocket-1.9.ebuild
new file mode 100644
index 000000000000..00ac9a2319d5
--- /dev/null
+++ b/app-emacs/websocket/websocket-1.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A websocket implementation in elisp"
+HOMEPAGE="https://github.com/ahyatt/emacs-websocket"
+SRC_URI="https://github.com/ahyatt/emacs-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/emacs-${P}"
+
+src_compile() {
+ elisp-compile websocket.el
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l websocket-test \
+ -f ert-run-tests-batch-and-exit
+}
+
+src_install() {
+ elisp-install ${PN} websocket.{el,elc}
+ dodoc README.org websocket-functional-test.el testserver.py
+}