summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-13 18:14:54 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-13 22:57:02 +0200
commita4cfc89f4faaa79e3e2df1f486a6a7a03dbfb572 (patch)
tree7e0461d8cce69466d2873492bcd7ac33e640718d /app-emacs
parentapp-emacs/php-mode: bump to 1.26.1 (diff)
downloadgentoo-a4cfc89f4faaa79e3e2df1f486a6a7a03dbfb572.tar.gz
gentoo-a4cfc89f4faaa79e3e2df1f486a6a7a03dbfb572.tar.bz2
gentoo-a4cfc89f4faaa79e3e2df1f486a6a7a03dbfb572.zip
app-emacs/plz: bump to 0.9.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/plz/Manifest1
-rw-r--r--app-emacs/plz/plz-0.9.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/plz/Manifest b/app-emacs/plz/Manifest
index 3ebbf19d58ec..2ac0f0c6679c 100644
--- a/app-emacs/plz/Manifest
+++ b/app-emacs/plz/Manifest
@@ -1 +1,2 @@
DIST plz-0.7.2.tar.gz 105864 BLAKE2B b876f69a61452ca932c70e87d35e4442f1ddae4c74c3e124056ff0adae9923d0a374c047a1c1dade705713a9b2aaa5bbfbb73368fde9564b53ce638f90f08ff0 SHA512 01951bbb0e59d6196338a806b4bab030538c411d185acf5462bc1eb4d3130b1da5d78a436e84163dd8167b3705edb6dcafdeef8d4611973521566d34f2ca5654
+DIST plz-0.9.1.tar.gz 102132 BLAKE2B 5680f08c4fb65fa8251b11aaaeacbe5c084731f1c90e27c5bd135da24943b6a1d2c7a0c4590d871f7b9cfb1c97a0fac6e453f707cdd96fca4d2e7f3dec257b9c SHA512 6e35e34accfba52428176345bfd07e1146587aed662c5df4443ba16ca02558a1137dc17ce7906d6e3ff296eb628ecca702d0f1595e504f0e102d4fb411ed295c
diff --git a/app-emacs/plz/plz-0.9.1.ebuild b/app-emacs/plz/plz-0.9.1.ebuild
new file mode 100644
index 000000000000..59d90c291da1
--- /dev/null
+++ b/app-emacs/plz/plz-0.9.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="HTTP library with curl backend for GNU Emacs"
+HOMEPAGE="https://github.com/alphapapa/plz.el/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/alphapapa/plz.el.git"
+else
+ SRC_URI="https://github.com/alphapapa/plz.el/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/plz.el-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+PROPERTIES="test_network" # Tests require network access.
+RESTRICT="test"
+
+RDEPEND="
+ net-misc/curl
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert tests -l tests/test-plz.el
+
+src_install() {
+ elisp_src_install
+
+ doinfo "${PN}.info"
+}