summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-11-26 11:10:49 +0100
committerUlrich Müller <ulm@gentoo.org>2019-11-26 11:38:59 +0100
commitb21e4c74285c8dd5fa00243c3ad136085bf9a675 (patch)
tree87780a24e3e1e7a2e71ec07f8793658626f776ee /app-emacs
parentapp-crypt/yubikey-manager: x86 stable (bug #701164) (diff)
downloadgentoo-b21e4c74285c8dd5fa00243c3ad136085bf9a675.tar.gz
gentoo-b21e4c74285c8dd5fa00243c3ad136085bf9a675.tar.bz2
gentoo-b21e4c74285c8dd5fa00243c3ad136085bf9a675.zip
app-emacs/jde: Drop dependency on app-emacs/elib.
avltree.el from elib was only required for compatibility with old Emacs versions. All versions >=emacs-23 include avl-tree.el, which will be properly detected in jde-parse.el. Other minor fixes to make repoman happy. Bug: https://bugs.gentoo.org/701160 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/jde/jde-2.4.1-r1.ebuild (renamed from app-emacs/jde/jde-2.4.1.ebuild)22
1 files changed, 11 insertions, 11 deletions
diff --git a/app-emacs/jde/jde-2.4.1.ebuild b/app-emacs/jde/jde-2.4.1-r1.ebuild
index fd50b7af19da..bddc407a7439 100644
--- a/app-emacs/jde/jde-2.4.1.ebuild
+++ b/app-emacs/jde/jde-2.4.1-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
JAVA_PKG_IUSE="doc source"
-inherit java-pkg-2 java-ant-2 elisp eutils
+inherit java-pkg-2 java-ant-2 elisp
DESCRIPTION="Java Development Environment for Emacs"
HOMEPAGE="http://jdee.sourceforge.net/"
@@ -16,8 +16,7 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-RDEPEND=">=virtual/jdk-1.3
- app-emacs/elib
+RDEPEND=">=virtual/jdk-1.3:=
dev-java/bsh:0
dev-java/junit:0
dev-util/checkstyle:0"
@@ -33,9 +32,10 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/${PN}-2.4.0.1-fix-paths-gentoo.patch"
- epatch "${FILESDIR}/${PN}-2.4.0.1-classpath-gentoo.patch"
- epatch "${FILESDIR}/${PN}-2.4.1-doc-directory.patch"
+ eapply "${FILESDIR}/${PN}-2.4.0.1-fix-paths-gentoo.patch"
+ eapply "${FILESDIR}/${PN}-2.4.0.1-classpath-gentoo.patch"
+ eapply "${FILESDIR}/${PN}-2.4.1-doc-directory.patch"
+ eapply_user
local bshjar csjar
bshjar=$(java-pkg_getjar --build-only bsh bsh.jar) || die
@@ -51,8 +51,7 @@ src_prepare() {
src_compile() {
ANT_TASKS="ant-contrib" \
- eant -Delib.dir="${EPREFIX}${SITELISP}/elib" \
- bindist $(usex doc source-doc "")
+ eant bindist $(usex doc source-doc "")
}
src_install() {
@@ -70,5 +69,6 @@ src_install() {
dobin ${dist}/lisp/jtags
- dohtml -r doc/html/*
+ dodoc -r doc/html
+ find "${ED}"/usr/share/doc -iname "*makefile" -delete || die
}