summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-17 15:32:21 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-17 15:39:34 +0200
commitf9771c99a1e43412c666ec48c669ee8fbfc92bb8 (patch)
treec9f1ab4acaa5144c2d481380a9d6eaa62d2308c6 /app-emacs
parentapp-admin/rsyslog: Stabilize 8.2306.0 amd64, #910654 (diff)
downloadgentoo-f9771c99a1e43412c666ec48c669ee8fbfc92bb8.tar.gz
gentoo-f9771c99a1e43412c666ec48c669ee8fbfc92bb8.tar.bz2
gentoo-f9771c99a1e43412c666ec48c669ee8fbfc92bb8.zip
app-emacs/git-timemachine: new package; add 4.13 and live 9999
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/git-timemachine/Manifest1
-rw-r--r--app-emacs/git-timemachine/files/50git-timemachine-gentoo.el7
-rw-r--r--app-emacs/git-timemachine/git-timemachine-4.13.ebuild27
-rw-r--r--app-emacs/git-timemachine/git-timemachine-9999.ebuild27
-rw-r--r--app-emacs/git-timemachine/metadata.xml13
5 files changed, 75 insertions, 0 deletions
diff --git a/app-emacs/git-timemachine/Manifest b/app-emacs/git-timemachine/Manifest
new file mode 100644
index 000000000000..b3bf0c98cf15
--- /dev/null
+++ b/app-emacs/git-timemachine/Manifest
@@ -0,0 +1 @@
+DIST git-timemachine-4.13.tar.gz 429649 BLAKE2B 8a0fc6185f0f2408f9953a59df5818e165ebd8703d429cd1abfcf671506b263228033b18ff14d1dc6a65f1c9b28ddc8461836a38eedf55c7a8415ca85374e8a1 SHA512 f47a169c16c07d4f80ba9539332d302b1539b0315eadf5ffbf7d55bb1c77124bef183b22641f321ca0c48ae61ed450d0f3133a7875ffce22272608d3fd3d74cb
diff --git a/app-emacs/git-timemachine/files/50git-timemachine-gentoo.el b/app-emacs/git-timemachine/files/50git-timemachine-gentoo.el
new file mode 100644
index 000000000000..0afabf3af5c1
--- /dev/null
+++ b/app-emacs/git-timemachine/files/50git-timemachine-gentoo.el
@@ -0,0 +1,7 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'git-timemachine-toggle "git-timemachine.el"
+ "Toggle git timemachine mode." t)
+(autoload 'git-timemachine "git-timemachine.el"
+ "Enable git timemachine for file of current buffer." t)
+(autoload 'git-timemachine-switch-branch "git-timemachine.el"
+ "Enable git timemachine for current buffer, switching to GIT-BRANCH." t)
diff --git a/app-emacs/git-timemachine/git-timemachine-4.13.ebuild b/app-emacs/git-timemachine/git-timemachine-4.13.ebuild
new file mode 100644
index 000000000000..34600dc73e46
--- /dev/null
+++ b/app-emacs/git-timemachine/git-timemachine-4.13.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Step through historic versions of git controlled files in GNU Emacs"
+HOMEPAGE="https://codeberg.org/pidu/git-timemachine/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://codeberg.org/pidu/${PN}.git"
+else
+ SRC_URI="https://codeberg.org/pidu/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/git-timemachine/git-timemachine-9999.ebuild b/app-emacs/git-timemachine/git-timemachine-9999.ebuild
new file mode 100644
index 000000000000..34600dc73e46
--- /dev/null
+++ b/app-emacs/git-timemachine/git-timemachine-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Step through historic versions of git controlled files in GNU Emacs"
+HOMEPAGE="https://codeberg.org/pidu/git-timemachine/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://codeberg.org/pidu/${PN}.git"
+else
+ SRC_URI="https://codeberg.org/pidu/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/git-timemachine/metadata.xml b/app-emacs/git-timemachine/metadata.xml
new file mode 100644
index 000000000000..5e8038e3d367
--- /dev/null
+++ b/app-emacs/git-timemachine/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://codeberg.org/pidu/git-timemachine/issues/</bugs-to>
+ <remote-id type="codeberg">pidu/git-timemachine</remote-id>
+ </upstream>
+</pkgmetadata>