summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-12-17 00:52:10 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-12-17 00:52:23 -0600
commit85bbb5fb5097ee28ad97da3172885d74e9e84236 (patch)
tree352572e89cb7afd564a8760e9df996310b60a113 /app-emulation/diskimage-builder
parentx11-libs/gdk-pixbuf: Stabilize 2.42.2 s390, #759094 (diff)
downloadgentoo-85bbb5fb5097ee28ad97da3172885d74e9e84236.tar.gz
gentoo-85bbb5fb5097ee28ad97da3172885d74e9e84236.tar.bz2
gentoo-85bbb5fb5097ee28ad97da3172885d74e9e84236.zip
app-emulation/diskimage-builder: 3.5.0 bump
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation/diskimage-builder')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.5.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index ab27dff6766a..57e63ee9abbd 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1,2 +1,3 @@
DIST diskimage-builder-3.3.1.tar.gz 450130 BLAKE2B 09f3b3549527d726f8479e1f8dc89ae50fdeacf6969e43f5b35591fa0a9d38ae0dd03b7292633604a938b0ef14e31b4e655645643bae22df4f3519c75d9dde83 SHA512 095c0968f5ceeb220c3871ccd14c7bf7c1b3d883bcb02f9cfe7406d5a336c36a813c8290bf133441a2a59972f485596aa5620b755016aba348afe3b7fc723c9f
DIST diskimage-builder-3.4.0.tar.gz 477142 BLAKE2B 998c4769f8b1e973628a6ab790c78afa32d3de23df6dda62e94917916aa92419d16a58ba3029bad6641508de2f404bfb16101197720ed050a1db6a92434e3144 SHA512 a05fc9b836cf8273d0c73ab1e95ecbd2172c56e457ba8ae00cb3a5f13b499dc1e8d81f262d155e8e2005bdc14af25370af9dfb3b2bf29342d5110edc7e630a87
+DIST diskimage-builder-3.5.0.tar.gz 477918 BLAKE2B 0621a4af9bc68a19c45d88ddbe636ae3e6e86cc1668023b0f10020bff51929a03c12edfced248fc138a114ad4b538d7b71828ed44a5d18b54e39bd47919b9699 SHA512 bea42f47078966686af9774ef34300f326e2ddf4b536af53d1378cf413e6675df9f71c54d90fdb55fbdeeefc708264350a48d4a4b2824d0bc3263df04742d768
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.5.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.5.0.ebuild
new file mode 100644
index 000000000000..eb082f7274ea
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"