summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-23 03:15:10 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-23 03:20:04 -0400
commitbc5460b747ada1490fb3958477084f647293df5e (patch)
tree895c88a11452e551ba9d493144f18094aca0017f /app-emulation/wine-vanilla
parentapp-emulation/vkd3d-proton: filter -fstack-clash-protection (diff)
downloadgentoo-bc5460b747ada1490fb3958477084f647293df5e.tar.gz
gentoo-bc5460b747ada1490fb3958477084f647293df5e.tar.bz2
gentoo-bc5460b747ada1490fb3958477084f647293df5e.zip
app-emulation/wine-vanilla: filter -fstack-clash-protection
Bug: https://bugs.gentoo.org/758914 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/wine-vanilla')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.0-r3.ebuild1
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.17.ebuild1
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.18.ebuild1
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.19.ebuild1
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild1
5 files changed, 5 insertions, 0 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.0-r3.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.0-r3.ebuild
index 893e362659d6..3ec318d2b900 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.0-r3.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.0-r3.ebuild
@@ -246,6 +246,7 @@ src_configure() {
# use *FLAGS for mingw, but strip unsupported (e.g. --hash-style=gnu)
if use mingw; then
: "${CROSSCFLAGS:=$(
+ filter-flags '-fstack-clash-protection' #758914
filter-flags '-fstack-protector*' #870136
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.17.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.17.ebuild
index ac4a2a6be890..4ad3720b207d 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.17.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.17.ebuild
@@ -244,6 +244,7 @@ src_configure() {
# use *FLAGS for mingw, but strip unsupported (e.g. --hash-style=gnu)
if use mingw; then
: "${CROSSCFLAGS:=$(
+ filter-flags '-fstack-clash-protection' #758914
filter-flags '-fstack-protector*' #870136
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.18.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.18.ebuild
index ac4a2a6be890..4ad3720b207d 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.18.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.18.ebuild
@@ -244,6 +244,7 @@ src_configure() {
# use *FLAGS for mingw, but strip unsupported (e.g. --hash-style=gnu)
if use mingw; then
: "${CROSSCFLAGS:=$(
+ filter-flags '-fstack-clash-protection' #758914
filter-flags '-fstack-protector*' #870136
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.19.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.19.ebuild
index ac4a2a6be890..4ad3720b207d 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.19.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.19.ebuild
@@ -244,6 +244,7 @@ src_configure() {
# use *FLAGS for mingw, but strip unsupported (e.g. --hash-style=gnu)
if use mingw; then
: "${CROSSCFLAGS:=$(
+ filter-flags '-fstack-clash-protection' #758914
filter-flags '-fstack-protector*' #870136
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index ac4a2a6be890..4ad3720b207d 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -244,6 +244,7 @@ src_configure() {
# use *FLAGS for mingw, but strip unsupported (e.g. --hash-style=gnu)
if use mingw; then
: "${CROSSCFLAGS:=$(
+ filter-flags '-fstack-clash-protection' #758914
filter-flags '-fstack-protector*' #870136
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(