summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-07-18 16:25:56 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-07-18 16:25:56 +0200
commitfe13a335bff1e0ebb1ac5d105ce4d067163e4154 (patch)
treed7e1feb8daff1aa1b37b6cc0200cb02ee9407694 /app-emulation
parentdev-python/PyGithub: Enable py3.7 (diff)
downloadgentoo-fe13a335bff1e0ebb1ac5d105ce4d067163e4154.tar.gz
gentoo-fe13a335bff1e0ebb1ac5d105ce4d067163e4154.tar.bz2
gentoo-fe13a335bff1e0ebb1ac5d105ce4d067163e4154.zip
app-emulation/containerd: Version bump to 1.1.2
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/containerd/Manifest1
-rw-r--r--app-emulation/containerd/containerd-1.1.2.ebuild55
-rw-r--r--app-emulation/containerd/metadata.xml2
3 files changed, 58 insertions, 0 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index 30ef8cd533fb..669fc87de20c 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -3,3 +3,4 @@ DIST containerd-1.0.3.tar.gz 3776722 BLAKE2B 31e9f2e56b23d09341e4cdd546198233517
DIST containerd-1.0.3_p20180223.tar.gz 5029605 BLAKE2B bd3f74ad70c7de9a73397e401e49459d1724376434265dddddd51cf09ccd940ecf63dacf0dc7270175d99e473c224ab238c0c29b0e03d41ddf9295ef37b90586 SHA512 a4999c1eb16c40178e3ee63f4001d4826d2dc6f353f768fbfdc6b7e0962d0f4431014fdedc712f36aee1e05554fecf1917ac48c1e25818b6c80a423ed7edddd9
DIST containerd-1.1.0.tar.gz 5095823 BLAKE2B 1eca83add164ed79abc58bfe424da9f34b54d247ad147ec0f4ae20154cabefe147fe9b03ce2eab04c88c240f00995eec5b0f24c0e064640738517b81e3e7aa3d SHA512 34e687c6ef270370160465ee9b8fe6b59780543907917b668db7867da67fd47c8465f57ba4268387f776d0f392f8dad533c206d6577bab36480aff4392775d42
DIST containerd-1.1.1.tar.gz 5123253 BLAKE2B e3e14311f4b444531b9b5d22ad7babd3fe9e7f4bf540c98153ebfc7445c34dad9c1268863e90a383bdab8630fc6576d1425e3e6a7f37e25fe6fb392aac389e2f SHA512 429070dbe0b486f8bbf5411c037e020f50fd008741091d6db1c13a0b526b2b4d0b22bb458401dd2ed142dc34e9bdcbd1ea30eabba39f11a50c294b94ce9867bd
+DIST containerd-1.1.2.tar.gz 5124208 BLAKE2B d989519d6bef4e12d1fa04aa00bfee223e94676a90525304d4357f4caf46326b4d2b897b885e9e137fe01ce66b93bc92fb7da7bd2b5dd5019edda5bb0bbc6d0a SHA512 fe4121a43e72a354cd87577b5227f2c2e0d54674244001e6fdb695da78873b3fd3f46b6bda6bbd0c8793b33f50e0d725cb356bb75b789a273c862bbe7d4f719c
diff --git a/app-emulation/containerd/containerd-1.1.2.ebuild b/app-emulation/containerd/containerd-1.1.2.ebuild
new file mode 100644
index 000000000000..2aebd40c4137
--- /dev/null
+++ b/app-emulation/containerd/containerd-1.1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/containerd/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_rc/-rc.}"
+ EGIT_COMMIT="v${MY_PV}"
+ CONTAINERD_COMMIT="468a545b9edcd5932818eb9de8e72413e616e86e"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="apparmor +btrfs +cri hardened +seccomp"
+
+DEPEND="btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp )"
+RDEPEND="|| ( >=app-emulation/docker-runc-1.0.0_rc4
+ >=app-emulation/runc-1.0.0_rc4 )
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ if [[ ${PV} != *9999* ]]; then
+ sed -i -e "s/git describe --match.*$/echo ${PV})/"\
+ -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
+ -e "s/-s -w//" \
+ Makefile || die
+ fi
+}
+
+src_compile() {
+ local options=( $(usex btrfs "" "no_btrfs") $(usex cri "" "no_cri") $(usex seccomp "seccomp" "") $(usex apparmor "apparmor" "") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin bin/containerd{-shim,-stress,} bin/ctr
+}
diff --git a/app-emulation/containerd/metadata.xml b/app-emulation/containerd/metadata.xml
index 7cc463053468..a28d7bea81ae 100644
--- a/app-emulation/containerd/metadata.xml
+++ b/app-emulation/containerd/metadata.xml
@@ -21,7 +21,9 @@
<name>William Hubbs</name>
</maintainer>
<use>
+ <flag name="apparmor">Support for AppArmor</flag>
<flag name="btrfs">Support for BTRFS snapshot driver</flag>
+ <flag name="cri">Support for Kubernetes CRI</flag>
</use>
<upstream>
<remote-id type="github">docker/containerd</remote-id>