summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-06-21 11:26:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-21 12:40:31 +0300
commit5f288354b74c0b6a5162290e57db28543f9f96f2 (patch)
tree62baf9ef37c19b5029e34678c8547e13b2a539c8 /app-i18n
parentapp-i18n/scim-sayura: EAPI 6 -> 8 (diff)
downloadgentoo-5f288354b74c0b6a5162290e57db28543f9f96f2.tar.gz
gentoo-5f288354b74c0b6a5162290e57db28543f9f96f2.tar.bz2
gentoo-5f288354b74c0b6a5162290e57db28543f9f96f2.zip
app-i18n/scim-anthy: EAPI 6 -> 8
Closes: https://bugs.gentoo.org/841791 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/scim-anthy/scim-anthy-1.2.7-r2.ebuild (renamed from app-i18n/scim-anthy/scim-anthy-1.2.7-r1.ebuild)35
1 files changed, 21 insertions, 14 deletions
diff --git a/app-i18n/scim-anthy/scim-anthy-1.2.7-r1.ebuild b/app-i18n/scim-anthy/scim-anthy-1.2.7-r2.ebuild
index 46e72aaa0156..d890045a6920 100644
--- a/app-i18n/scim-anthy/scim-anthy-1.2.7-r1.ebuild
+++ b/app-i18n/scim-anthy/scim-anthy-1.2.7-r2.ebuild
@@ -1,30 +1,36 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
-SRC_URI="mirror://sourceforge.jp/scim-imengine/37309/${P}.tar.gz
- https://dev.gentoo.org/~juippis/distfiles/tmp/scim-anthy-1.2.7-gtk2_build.patch
- gtk3? ( https://dev.gentoo.org/~heroxbd/${P}-patches.tar.xz )"
+SRC_URI="
+ mirror://sourceforge.jp/scim-imengine/37309/${P}.tar.gz
+ https://dev.gentoo.org/~juippis/distfiles/tmp/${PN}-1.2.7-gtk2_build.patch
+ gtk3? ( https://dev.gentoo.org/~heroxbd/${P}-patches.tar.xz )
+"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ppc sparc x86"
IUSE="+gtk3 nls kasumi"
-DEPEND=">=app-i18n/scim-1.2[gtk3=]
+DEPEND="
>=app-i18n/anthy-5900
+ >=app-i18n/scim-1.2[gtk3=]
nls? ( virtual/libintl )
- gtk3? ( x11-libs/gtk+:3 )"
+ gtk3? ( x11-libs/gtk+:3 )
+"
RDEPEND="${DEPEND}
- kasumi? ( app-dicts/kasumi )"
-DEPEND="${DEPEND}
+ kasumi? ( app-dicts/kasumi )
+"
+BDEPEND="
nls? ( sys-devel/gettext )
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
src_prepare() {
default
@@ -39,12 +45,13 @@ src_prepare() {
}
src_configure() {
- econf \
- $(use_enable nls) \
- --disable-static
+ econf $(use_enable nls)
}
src_install() {
+ local DOCS=( AUTHORS ChangeLog NEWS README )
default
- dodoc AUTHORS ChangeLog NEWS README
+
+ # plugin module, no point in .la files
+ find "${D}" -type f -name '*.la' -delete || die
}