summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-17 11:56:25 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-17 11:58:11 -0600
commit6affab57a1369437b7b27503d8fdcf4632f34227 (patch)
treeb62a2bccf13c5514b143176721f0e81a4e9cc651 /app-metrics
parentsci-mathematics/ent: update DESCRIPTION, HOMEPAGE (diff)
downloadgentoo-6affab57a1369437b7b27503d8fdcf4632f34227.tar.gz
gentoo-6affab57a1369437b7b27503d8fdcf4632f34227.tar.bz2
gentoo-6affab57a1369437b7b27503d8fdcf4632f34227.zip
app-metrics/prometheus: add 2.37.5
I was asked to add this back to the tree since it is an lts version. Most users will not need to downgrade to this since it will expire at the end of Jan. Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/prometheus/Manifest3
-rw-r--r--app-metrics/prometheus/prometheus-2.37.5.ebuild72
2 files changed, 75 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index d8aed812617a..8a617154e4f7 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -1,3 +1,6 @@
+DIST prometheus-2.37.5-assets.tar.xz 43891228 BLAKE2B f0bf050e9de3d790fd826c96b176a9d44292435e21df6fefc47c53f1a0bd71838711120155b64b6696a98aa6babcb8388ca5711b2a1ac5b6a653628f9890513d SHA512 639c3a84ea2b2f75d646feb21f1b33276fe06aa3c76348a34bd7b1173e2525d7de6ff313c049923eb142c617a26c065034a22b72b8f57c4e2c552f19d8294da5
+DIST prometheus-2.37.5-deps.tar.xz 251720200 BLAKE2B 78ddab5fee6f0f64c7413058e622fd40e3e486318e5749befb3f204e2df52dada16ecad755c02d0583826b80904b53d41a973c348f1af6462cd077f2157c38e4 SHA512 eed981ff5ae07f79fbb38d59905c124b1766d3047bcf103aa416379f9d370cc0ad878a15aceacd0a450100166b9c8e1c7c5dae9605c3bcd9f96bd89929b41136
+DIST prometheus-2.37.5.tar.gz 6048663 BLAKE2B c3dfaee0093f50ce5a9bfe7fd27a21d77593fa983838d89a30f890fcccd543c1d3dda35e7bbb01181649321b6b652c9aac83f8d247bd28058b4fb5a7f4e10f0c SHA512 3c3617e03b036bc1a7a7347d57823c2fa342a5aa4a113ddcc6af2367c2be90ba71042208eb146ed50320e9f6a8ab55edb8239aadb5654c76590b46249fac8bd6
DIST prometheus-2.40.4-assets.tar.xz 45585656 BLAKE2B b187b6683c778b5e9746f1f9695e03303cf5481387bb0517afee56685edc62bbb82c515f8dfeeafeb09a74b57b540da49d1936c7ec74b3013adc7afc8f07ea5f SHA512 8a229504b66bac0ef2fa7a9caafc93fdf3e1c9aa33e892219e57a21b44355515e69a232db98ce4f5664fb98cb37cfb3ec619eb2a3ccf662474544dfdbbba580c
DIST prometheus-2.40.4-deps.tar.xz 253189332 BLAKE2B ca2c2f3e111897ac47d71acc3046230608134c854f7af7a4c5ec1fe75dfbb61c6bf278fe00f77ecf65113b72cbd67171634a0fbf57ad09e3349a7e8f45791e33 SHA512 29bf419e45d389805b1f37256cb8a9ce9cc6cb88b3cd4a7a1681121f24158cce7aa5a949554f5344409ba4f683976866bfc766666e2a0a247996c135d2068b6f
DIST prometheus-2.40.4.tar.gz 6156657 BLAKE2B a522b31516f5e26475afa2d59a7074b7deb2a70ffbf7cce6e3951bfeacc6dae6d8f59d1b1b591d1c59c0ac9839bc691ce315d55f7fe0a45be573e124f651764b SHA512 9b46f9f3b986929bdfe365645e43c0a3c2073b920e59cc512287f866506d7db7b83ffb2dbe24d1835fccc1b2cc781be7a373da5fb58c04521648981b19e81737
diff --git a/app-metrics/prometheus/prometheus-2.37.5.ebuild b/app-metrics/prometheus/prometheus-2.37.5.ebuild
new file mode 100644
index 000000000000..02d3f583d761
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.37.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+GIT_COMMIT=414d31aee6586a5f29e755ae059b7d7131f1c6c8
+MY_PV=v${PV/_rc/-rc.}
+
+# To create the assets tarball run the following:
+# git checkout <tag>
+# make assets-compress
+# tar -acf <tarball> web/ui
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="https://github.com/prometheus/prometheus/archive/${MY_PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz
+ https://dev.gentoo.org/~williamh/dist/${P}-assets.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~riscv"
+
+COMMON_DEPEND="acct-group/prometheus
+ acct-user/prometheus"
+DEPEND="!app-metrics/prometheus-bin
+ ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND=">=dev-util/promu-0.3.0"
+
+RESTRICT=" test"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s/{{.Branch}}/HEAD/" \
+ -e "s/{{.Revision}}/${GIT_COMMIT}/" \
+ -e "s/{{.Version}}/${PV}/" \
+ .promu.yml || die
+ cp -a -n "${WORKDIR}"/web/ui web || die
+}
+
+src_compile() {
+ emake PROMU="${EPREFIX}"/usr/bin/promu common-build plugins
+}
+
+src_install() {
+ dobin prometheus promtool
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ dosym -r /usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym -r /usr/share/prometheus/consoles /etc/prometheus/consoles
+
+ systemd_dounit "${FILESDIR}"/prometheus.service
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}