summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-06-18 17:49:54 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-06-18 17:50:24 -0500
commit79ebe8b1ac7c697bfb485b1b40f0a94eabf2eeee (patch)
tree09381c265dc7336f07104db5f3eeb8fb596c4f0e /app-metrics
parentprofiles/base: package.use.force >=qtmultimedia-6.7.2[v4l] for now (diff)
downloadgentoo-79ebe8b1ac7c697bfb485b1b40f0a94eabf2eeee.tar.gz
gentoo-79ebe8b1ac7c697bfb485b1b40f0a94eabf2eeee.tar.bz2
gentoo-79ebe8b1ac7c697bfb485b1b40f0a94eabf2eeee.zip
app-metrics/prometheus: add 2.52.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/prometheus/Manifest3
-rw-r--r--app-metrics/prometheus/prometheus-2.52.0.ebuild72
2 files changed, 75 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index d049f5612269..b64510c62e77 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -7,3 +7,6 @@ DIST prometheus-2.43.0.tar.gz 6228230 BLAKE2B d004bb077c70849e7d9e0c28420582475f
DIST prometheus-2.47.0-assets.tar.xz 40992964 BLAKE2B d7eff81d429a482c819269bdb7d67b76dd74b63a70112a2b34ee7eeaa9c9b4049b4c9f2c56aa6468baa9be1454028a1d7b8721bc23c057091e8c1671b266729a SHA512 a8f904a24d8243a26a71b7ab947a465713a6f9185878d0a86ed5c2c665b887f12e74daf6aef6997d290837a3da02160235aef8acb85ba401203d616c34e08e37
DIST prometheus-2.47.0-deps.tar.xz 337362600 BLAKE2B 03d86183f55cf7ac84e6ccae91fad3bed590a9ba1bd22fbd9b0f3148c6b1367b86af29dad4988c66b28e2b69570940523b1e78ae6ec1b6bd68a744455688beaf SHA512 27edb6aad9bf134c3c061f06b6e96787cd48a19d7ae42c9fa04b86bd6c98b62c1f558030266b0882ad668da268d6794605b017f335d3ad4128a41ca6f5e0d241
DIST prometheus-2.47.0.tar.gz 6335136 BLAKE2B 10a4d2bb53b8c6cd5f26ab28155673f1d5ea08cc6e070350af9b09d9868dd39a073f9747c0836490be0fc5f33a2d461b5eb8087c3ab469feb940a6e9795c094c SHA512 1d8d91512d3edc7f56bd0e96b398e9680dd5fd39d2ac2e7e3f52d7bccc30ead4e4d0f238886d80d41d980a89c20123e0b29ce6eec9d8799f5581b147f3ef79ea
+DIST prometheus-2.52.0-assets.tar.xz 40948988 BLAKE2B 6c5812c7b0470e796f9f052be4c4248ee4dcacbaeccd0aa5bb136a4775ce939870f9b366cd87ec325cd93364e69e04b1bbef461842d6fe850cd7e3d9d08fd652 SHA512 0f12548dd97a0aa19379a3090fcad7002cd2917cff59937630302edb6d9f6be49b91476111f9ef23bc3f4a009f2a9ff871e1fa78a765543fd7ac9eacd0233228
+DIST prometheus-2.52.0-deps.tar.xz 136485640 BLAKE2B aba4869ca0aa810c9651737f9089c0a5c64ec6f54f9bb1fec7e8e51fbc3042033e4935128af59cf5f9059e2815119e95b1bd8db4d1ce316f2a5af2d32913e2c4 SHA512 11c63ba8a96a8cad655d6f66accb4528d4562c21f9cec671d63120246d3a963690d0d27b0e41e3a24882e2c111b42e0f678d244ebb8a712a794f90eb9b415b5c
+DIST prometheus-2.52.0.tar.gz 6192779 BLAKE2B 488483b32ee0927f2d0aa5d7bd1f82dee39c0e8273244a0260421f1523c2555541d35d02d869d2a35b434d41ff3210ce9da4a5430ae1f5a41a9d7e250d24246f SHA512 6ad5825ee6dfe6ba82ad8f091cb1fd8bfaf323558f0171c8e16fccb070fa99865cc9e9137a60405a5ec7c90706469cefefbe25c47e47bc37c30de671981955e3
diff --git a/app-metrics/prometheus/prometheus-2.52.0.ebuild b/app-metrics/prometheus/prometheus-2.52.0.ebuild
new file mode 100644
index 000000000000..b170685f7e08
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.52.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+GIT_COMMIT=879d80922a227c37df502e7315fad8ceb10a986d
+MY_PV=v${PV/_rc/-rc.}
+
+# To create the assets tarball run the following:
+# git checkout <tag>
+# make assets-compress
+# tar -acf <tarball> web/ui
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="https://github.com/prometheus/prometheus/archive/${MY_PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz
+ https://dev.gentoo.org/~williamh/dist/${P}-assets.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+
+COMMON_DEPEND="acct-group/prometheus
+ acct-user/prometheus"
+DEPEND="!app-metrics/prometheus-bin
+ ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND=">=dev-util/promu-0.3.0"
+
+RESTRICT=" test"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s/{{.Branch}}/HEAD/" \
+ -e "s/{{.Revision}}/${GIT_COMMIT}/" \
+ -e "s/{{.Version}}/${PV}/" \
+ .promu.yml || die
+ cp -a -u "${WORKDIR}"/web/ui web || die "cp failed"
+}
+
+src_compile() {
+ emake PROMU="${EPREFIX}"/usr/bin/promu common-build plugins
+}
+
+src_install() {
+ dobin prometheus promtool
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ dosym -r /usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym -r /usr/share/prometheus/consoles /etc/prometheus/consoles
+
+ systemd_dounit "${FILESDIR}"/prometheus.service
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}