summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2023-08-26 11:05:47 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-15 07:54:07 +0300
commita9ccc48242da316f37b8e6ddf99bae660fadef48 (patch)
tree3d089d31fe8ad556f1d3a014901cd8d6356d5af0 /app-misc/boxes/boxes-2.2.1.ebuild
parentsys-cluster/glusterfs: drop 10.2-r2 (diff)
downloadgentoo-a9ccc48242da316f37b8e6ddf99bae660fadef48.tar.gz
gentoo-a9ccc48242da316f37b8e6ddf99bae660fadef48.tar.bz2
gentoo-a9ccc48242da316f37b8e6ddf99bae660fadef48.zip
app-misc/boxes: add 2.2.1
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/32456 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-misc/boxes/boxes-2.2.1.ebuild')
-rw-r--r--app-misc/boxes/boxes-2.2.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/boxes/boxes-2.2.1.ebuild b/app-misc/boxes/boxes-2.2.1.ebuild
new file mode 100644
index 000000000000..fd1e85729afa
--- /dev/null
+++ b/app-misc/boxes/boxes-2.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Draw any kind of boxes around your text"
+HOMEPAGE="https://boxes.thomasjensen.com/ https://github.com/ascii-boxes/boxes"
+SRC_URI="https://github.com/ascii-boxes/boxes/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libpcre2[pcre32]
+ dev-libs/libunistring:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ test? ( app-editors/vim-core )
+"
+
+src_prepare() {
+ default
+
+ sed \
+ -e 's:STRIP=true:STRIP=false:g' \
+ -i src/Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS_ADDTL="${CFLAGS}" LDFLAGS_ADDTL="${LDFLAGS}"
+}
+
+src_install() {
+ dobin out/boxes
+ doman doc/boxes.1
+ insinto /usr/share
+ newins boxes-config boxes
+ einstalldocs
+}