summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/getopt/getopt-1.1.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/getopt/getopt-1.1.6.ebuild')
-rw-r--r--app-misc/getopt/getopt-1.1.6.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/app-misc/getopt/getopt-1.1.6.ebuild b/app-misc/getopt/getopt-1.1.6.ebuild
new file mode 100644
index 000000000000..52424263d9bc
--- /dev/null
+++ b/app-misc/getopt/getopt-1.1.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="getopt(1) replacement supporting GNU-style long options"
+HOMEPAGE="http://software.frodo.looijaard.name/getopt/"
+SRC_URI="http://frodo.looijaard.name/system/files/software/getopt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.5-libintl.patch
+ epatch "${FILESDIR}"/${PN}-1.1.5-setlocale.patch
+ epatch "${FILESDIR}"/${PN}-1.1.6-longrename.patch
+
+ # hopefully this is portable enough
+ epatch "${FILESDIR}"/${PN}-1.1.4-irix.patch
+}
+
+src_compile() {
+ local nogettext="1"
+ local libintl=""
+ local libcgetopt=1
+
+ if use nls; then
+ nogettext=0
+ has_version sys-libs/glibc || libintl="-lintl"
+ fi
+
+ [[ ${CHOST} == *-aix* ]] && libcgetopt=0
+ [[ ${CHOST} == *-irix* ]] && libcgetopt=0
+ [[ ${CHOST} == *-interix* ]] && libcgetopt=0
+
+ emake CC="$(tc-getCC)" prefix="${EPREFIX}/usr" \
+ LIBCGETOPT=${libcgetopt} \
+ WITHOUT_GETTEXT=${nogettext} LIBINTL=${libintl} \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ use nls && emake prefix="${EPREFIX}/usr" DESTDIR="${D}" install_po
+
+ newbin getopt getopt-long
+
+ # at least on interix, the system getopt is ... broken...
+ # util-linux, which would provide the getopt binary, does not build &
+ # install on interix/prefix, so, this has to provide it.
+ [[ ${CHOST} == *-interix* || ${CHOST} == *-mint* ]] && \
+ dosym getopt-long /usr/bin/getopt
+
+ newman getopt.1 getopt-long.1
+
+ dodoc getopt-*sh
+}