summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/granule
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/granule')
-rw-r--r--app-misc/granule/Manifest1
-rw-r--r--app-misc/granule/files/granule-1.4.0-fix-template-with-permissive.patch15
-rw-r--r--app-misc/granule/granule-1.4.0.ebuild39
-rw-r--r--app-misc/granule/metadata.xml11
4 files changed, 66 insertions, 0 deletions
diff --git a/app-misc/granule/Manifest b/app-misc/granule/Manifest
new file mode 100644
index 000000000000..13eb2581c093
--- /dev/null
+++ b/app-misc/granule/Manifest
@@ -0,0 +1 @@
+DIST granule-1.4.0-7.tar.gz 677428 SHA256 356463f586b8b6147a05ab00ca8b5e7f8f85d2ec3981fbb9c0c0c2e2da6f58c9 SHA512 a5e3640c06b573a2bca01a4b893fec7ff363185e121a09c23f99297651518f7745f130b31165c47ee0c603c3ff2f59d996197c4b507edc8487998ddb80cef8b6 WHIRLPOOL 54f13dea2f0aa0a56e5b9f382c9b677d75293b26dce2acc3b6ecfa049844389c53a8dcab3e857220ef24b8bb545ffe3a479c9db520916944686044afe851a6d0
diff --git a/app-misc/granule/files/granule-1.4.0-fix-template-with-permissive.patch b/app-misc/granule/files/granule-1.4.0-fix-template-with-permissive.patch
new file mode 100644
index 000000000000..252c41e77973
--- /dev/null
+++ b/app-misc/granule/files/granule-1.4.0-fix-template-with-permissive.patch
@@ -0,0 +1,15 @@
+Description: Fix build with gcc4.8 and -fpermissive
+Bug-Debian: http://bugs.debian.org/701292
+Last-Update: 2013-08-11
+
+--- granule-1.4.0-7.orig/src/Granule.cpp
++++ granule-1.4.0-7/src/Granule.cpp
+@@ -56,7 +56,7 @@ ASSA_DECL_SINGLETON(Granule);
+
+ static const int TIMEOUT = 2000; // 2 seconds (1,000 mls = 1 sec).
+
+-template <> xmlExternalEntityLoader Granule::m_default_entity_loader = 0;
++xmlExternalEntityLoader Granule::m_default_entity_loader = 0;
+
+ /*******************************************************************************
+ Member Functions
diff --git a/app-misc/granule/granule-1.4.0.ebuild b/app-misc/granule/granule-1.4.0.ebuild
new file mode 100644
index 000000000000..e4cb4d359246
--- /dev/null
+++ b/app-misc/granule/granule-1.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+inherit eutils
+
+DESCRIPTION="A flashcard program that implements Leitner cardfile methodology"
+HOMEPAGE="http://granule.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-7.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-cpp/gtkmm-2.4.1:2.4
+ >=dev-cpp/libassa-3.5.0
+ x11-libs/gtk+:2
+ dev-cpp/glibmm:2
+ >=dev-libs/libsigc++-2.0
+ x11-libs/pango
+ dev-libs/glib:2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/intltool
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${P}-7"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-template-with-permissive.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/app-misc/granule/metadata.xml b/app-misc/granule/metadata.xml
new file mode 100644
index 000000000000..a217de5054de
--- /dev/null
+++ b/app-misc/granule/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">granule</remote-id>
+ </upstream>
+</pkgmetadata>