summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/mmv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/mmv')
-rw-r--r--app-misc/mmv/Manifest3
-rw-r--r--app-misc/mmv/metadata.xml5
-rw-r--r--app-misc/mmv/mmv-1.01b_p15.ebuild50
-rw-r--r--app-misc/mmv/mmv-1.01b_p18.ebuild50
4 files changed, 108 insertions, 0 deletions
diff --git a/app-misc/mmv/Manifest b/app-misc/mmv/Manifest
new file mode 100644
index 000000000000..94adcdd0ada8
--- /dev/null
+++ b/app-misc/mmv/Manifest
@@ -0,0 +1,3 @@
+DIST mmv_1.01b-15.diff.gz 10613 SHA256 9ad3e3d47510f816b4a18bae04ea75913588eec92248182f85dd09bc5ad2df13 SHA512 965db30f8981a973c93dec14348c451604fe37fbd5576d5eb0e38de8cef21e5b6c9a3560e46725b6beaac2d9722cb9a874f7eb2b5e9d9cdf22e67eb367991550 WHIRLPOOL 4374d053e65c05747509b4a3759b3330e45504b8325ae60f6e70ed67317e5a6383adf334f73e05f2a1ef89b884452169e5a437d583ef402bb4001ee544034210
+DIST mmv_1.01b-18.debian.tar.gz 13463 SHA256 4af5c83cacb27c7720bf65cac9a4f6c1fe698474a716e2df0fbad9181e6844e7 SHA512 3543aff53c67cab00689d4c8b778447c976a7860a569bd51f74534bec8bd3b67b9e12743bd03bc6fda930748abddd12e16f1965686cbce04bd48bf191fc4127b WHIRLPOOL 57dd2ebb1d075f9479d0466cc39f4cf3ebe3e8457b96a56a0f5d1b63c6ada01ec281fcf5e79220e07256aa1edfb046d8ddf75df8ab6c1ac25ff67074c0760ed2
+DIST mmv_1.01b.orig.tar.gz 25656 SHA256 0399c027ea1e51fd607266c1e33573866d4db89f64a74be8b4a1d2d1ff1fdeef SHA512 4bf4e096b930bdde225ba5de761e968af3aed33dc13194b1a1a79078cd27e158b04aae131b5167cf5f844e35355d67359443cd598db22da15a5af06752438917 WHIRLPOOL 318484c12416174535ba6e77929798418943ae521e339a7f68b1b7a488b4058cbe88de019e07b705879597ef04d6c325c15d2869b224827dca6d9519c8772aa5
diff --git a/app-misc/mmv/metadata.xml b/app-misc/mmv/metadata.xml
new file mode 100644
index 000000000000..40149c995561
--- /dev/null
+++ b/app-misc/mmv/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+</pkgmetadata>
diff --git a/app-misc/mmv/mmv-1.01b_p15.ebuild b/app-misc/mmv/mmv-1.01b_p15.ebuild
new file mode 100644
index 000000000000..ec7fa57ddfe9
--- /dev/null
+++ b/app-misc/mmv/mmv-1.01b_p15.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DEB_PATCH_VER=${PV#*_p}
+MY_VER=${PV%_p*}
+
+DESCRIPTION="Move/copy/append/link multiple files according to a set of wildcard patterns"
+HOMEPAGE="http://packages.debian.org/unstable/utils/mmv"
+SRC_URI="
+ mirror://debian/pool/main/m/mmv/${PN}_${MY_VER}.orig.tar.gz
+ mirror://debian/pool/main/m/mmv/${PN}_${MY_VER}-${DEB_PATCH_VER}.diff.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}"/${PN}-${MY_VER}.orig
+
+src_prepare() {
+ epatch "${DISTDIR}"/${PN}_${MY_VER}-${DEB_PATCH_VER}.diff.gz
+}
+
+src_compile() {
+ # i wonder how this works on other platforms if CFLAGS from makefile are
+ # overridden, see bug #218082
+ [[ ${CHOST} == *-interix* ]] && append-flags -DIS_SYSV -DHAS_RENAME -DHAS_DIRENT
+ [[ ${CHOST} == *-interix* ]] || append-lfs-flags
+
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin mmv || die
+ dosym mmv /usr/bin/mcp || die
+ dosym mmv /usr/bin/mln || die
+ dosym mmv /usr/bin/mad || die
+
+ doman mmv.1 || die
+ newman mmv.1 mcp.1 || die
+ newman mmv.1 mln.1 || die
+ newman mmv.1 mad.1 || die
+
+ dodoc ANNOUNCE debian/{changelog,control} || die
+}
diff --git a/app-misc/mmv/mmv-1.01b_p18.ebuild b/app-misc/mmv/mmv-1.01b_p18.ebuild
new file mode 100644
index 000000000000..582fa4e005f8
--- /dev/null
+++ b/app-misc/mmv/mmv-1.01b_p18.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DEB_PATCH_VER=${PV#*_p}
+MY_VER=${PV%_p*}
+
+DESCRIPTION="Move/copy/append/link multiple files according to a set of wildcard patterns"
+HOMEPAGE="http://packages.debian.org/unstable/utils/mmv"
+SRC_URI="
+ mirror://debian/pool/main/m/mmv/${PN}_${MY_VER}.orig.tar.gz
+ mirror://debian/pool/main/m/mmv/${PN}_${MY_VER}-${DEB_PATCH_VER}.debian.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}"/${PN}-${MY_VER}.orig
+
+src_prepare() {
+ epatch "${WORKDIR}"/debian/patches/*.diff
+}
+
+src_compile() {
+ # i wonder how this works on other platforms if CFLAGS from makefile are
+ # overridden, see bug #218082
+ [[ ${CHOST} == *-interix* ]] && append-flags -DIS_SYSV -DHAS_RENAME -DHAS_DIRENT
+ [[ ${CHOST} == *-interix* ]] || append-lfs-flags
+
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin mmv
+ dosym mmv /usr/bin/mcp
+ dosym mmv /usr/bin/mln
+ dosym mmv /usr/bin/mad
+
+ doman mmv.1
+ newman mmv.1 mcp.1
+ newman mmv.1 mln.1
+ newman mmv.1 mad.1
+
+ dodoc ANNOUNCE "${WORKDIR}"/debian/{changelog,control}
+}