summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-06 02:02:20 +0100
committerSam James <sam@gentoo.org>2023-04-06 02:02:20 +0100
commitefa5d29f7b4c6686f19a181e0a05cd6f790f237b (patch)
tree8fe011ae87508ed5332f395febc89e551a82588b /app-office/libreoffice/libreoffice-9999.ebuild
parentdev-lang/python: add timeout for PGO task for >= 3.10 (diff)
downloadgentoo-efa5d29f7b4c6686f19a181e0a05cd6f790f237b.tar.gz
gentoo-efa5d29f7b4c6686f19a181e0a05cd6f790f237b.tar.bz2
gentoo-efa5d29f7b4c6686f19a181e0a05cd6f790f237b.zip
app-office/libreoffice: filter out -Wlto-type-mismatch for USE=clang
Clang doesn't implement this yet. Closes: https://bugs.gentoo.org/903889 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office/libreoffice/libreoffice-9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 93f656a18661..2070a4f324ae 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -400,6 +400,9 @@ src_configure() {
NM=llvm-nm
RANLIB=llvm-ranlib
LDFLAGS+=" -fuse-ld=lld"
+
+ # Not implemented by Clang, bug #903889
+ filter-flags -Wlto-type-mismatch -Werror=lto-type-mismatch
else
# Force gcc
einfo "Enforcing the use of gcc due to USE=-clang ..."