summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-27 14:02:29 +0000
committerSam James <sam@gentoo.org>2024-12-27 14:02:29 +0000
commit272565732fd7e114a6bcd8b6f40b411b5f79d713 (patch)
tree2db9883f43da4a79dc94e0528ea9a28204b70d29 /app-office
parentsys-apps/cracklib-words: add 2.10.3 (diff)
downloadgentoo-272565732fd7e114a6bcd8b6f40b411b5f79d713.tar.gz
gentoo-272565732fd7e114a6bcd8b6f40b411b5f79d713.tar.bz2
gentoo-272565732fd7e114a6bcd8b6f40b411b5f79d713.zip
app-office/mdbtools: add 1.0.1
Closes: https://bugs.gentoo.org/915495 Closes: https://bugs.gentoo.org/940602 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/mdbtools/Manifest1
-rw-r--r--app-office/mdbtools/mdbtools-1.0.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-office/mdbtools/Manifest b/app-office/mdbtools/Manifest
index de6d5f2731d4..484378e241db 100644
--- a/app-office/mdbtools/Manifest
+++ b/app-office/mdbtools/Manifest
@@ -1 +1,2 @@
DIST mdbtools-1.0.0.tar.gz 220553 BLAKE2B 55cf3120f16ded1374c0b5535c45a0d15e4d2ec62d4029856bea570282e6099565698c00b27295b01b455eca10d9271e743e60086b427647dfe51c25d65c531d SHA512 3844bde9df3a5beafa40914fef3db25a9b3bc0e66cbd012fd6ad0fcf89e66f48afa922be61972b4d6a7a3d0ba0bf1881f7d8fdebce7f52f19254133dd1d3fc5f
+DIST mdbtools-1.0.1.tar.gz 672774 BLAKE2B c95c4cf343f7261e08eecf5f65be8302cd6491fc6b5d810054a9a2e614e67e8848a157734a41dd200f1ee8c299d5d52d24402574f9f039da537f47f3c2618888 SHA512 3f033db4c036f53f800982b5499a64756d3a859d9284ef5202a7062dc7a2d1ef1a657d43b8ea3f76aa999f5adcc4b3799eaaa8b8084adf6f60d55ba9ccc78b72
diff --git a/app-office/mdbtools/mdbtools-1.0.1.ebuild b/app-office/mdbtools/mdbtools-1.0.1.ebuild
new file mode 100644
index 000000000000..e41a119ce886
--- /dev/null
+++ b/app-office/mdbtools/mdbtools-1.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Set of libraries and utilities for reading Microsoft Access database (MDB) files"
+HOMEPAGE="https://github.com/mdbtools/mdbtools"
+SRC_URI="https://github.com/mdbtools/mdbtools/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="glib iconv odbc"
+
+BDEPEND="
+ app-text/txt2man
+ sys-devel/bison
+ sys-devel/flex
+ sys-apps/which
+ virtual/pkgconfig
+"
+RDEPEND="
+ sys-libs/ncurses:=
+ sys-libs/readline:=
+ glib? ( >=dev-libs/glib-2.68:2 )
+ iconv? ( virtual/libiconv )
+ odbc? ( >=dev-db/unixODBC-2.0 )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # bug #915495
+ unset YACC LEX
+
+ local myeconfargs=(
+ $(use_enable glib)
+ $(use_enable iconv)
+ $(use odbc && echo "--with-unixodbc=${EPREFIX}/usr")
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}