summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-07-04 20:59:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-04 21:36:19 +0300
commitb30c73492076e6235027216dc5c0e64861e779d0 (patch)
treea4419eb259f444277228b803054e7cab6e48ec03 /app-office
parentapp-office/lyx: drop 2.3.7, 2.4.0_rc4 (diff)
downloadgentoo-b30c73492076e6235027216dc5c0e64861e779d0.tar.gz
gentoo-b30c73492076e6235027216dc5c0e64861e779d0.tar.bz2
gentoo-b30c73492076e6235027216dc5c0e64861e779d0.zip
app-office/lyx: add 2.4.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx/Manifest1
-rw-r--r--app-office/lyx/lyx-2.4.1.ebuild180
2 files changed, 181 insertions, 0 deletions
diff --git a/app-office/lyx/Manifest b/app-office/lyx/Manifest
index 808d514d5023..94fd4d2c267a 100644
--- a/app-office/lyx/Manifest
+++ b/app-office/lyx/Manifest
@@ -1 +1,2 @@
DIST lyx-2.4.0.tar.xz 17823824 BLAKE2B 924425bbbbc50c1e1b03e493a021be4f9b56344712407b46dc1ec75bd583f0f9803592d3fbdca70fdefdbb60056f0275ab4a25e251f728ed710ef796b50f711e SHA512 b52724a7f544f190c93b948c11b835057f73e417115cf67a5e586f6872816b3a4df7429d24b5323410a34a79f725052db57105649ff6c275141f97d391a2091b
+DIST lyx-2.4.1.tar.xz 17848700 BLAKE2B 5e9d9530610149a1b0f6a7d536068ff0da97e261a6069a9efc3c45a892c653e7accadcd0bde96bf3ffad9d936fef4a4b88ee7b5233f875bbc568044376a5b37e SHA512 80d57d46dab61ecb655c9d54ba1d20203ad943db5249ed16dbeb5b78b7845896a79224c8032213cc861fd943629fbe87ef8ac9155cc9b34da9be2f59eb087071
diff --git a/app-office/lyx/lyx-2.4.1.ebuild b/app-office/lyx/lyx-2.4.1.ebuild
new file mode 100644
index 000000000000..d9d8f324a88f
--- /dev/null
+++ b/app-office/lyx/lyx-2.4.1.ebuild
@@ -0,0 +1,180 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit desktop font optfeature python-single-r1 cmake xdg
+
+DESCRIPTION="WYSIWYM (What You See Is What You Mean) document processor based on LaTeX"
+HOMEPAGE="https://www.lyx.org/"
+SRC_URI="http://ftp.lyx.org/pub/lyx/devel/lyx-$(ver_cut 1-2)/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="aspell cups dia dot enchant gnumeric html +hunspell +latex monolithic-build nls rcs rtf svg l10n_he"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ app-text/mythes
+ dev-libs/boost:=
+ sys-apps/file
+ sys-libs/zlib:=
+ virtual/imagemagick-tools[png,svg?]
+ x11-misc/xdg-utils
+
+ dev-qt/qtbase:6[concurrent,dbus,gui,widgets]
+ dev-qt/qt5compat:6
+ dev-qt/qtsvg:6
+
+ aspell? ( app-text/aspell )
+ cups? ( net-print/cups )
+ dia? ( app-office/dia )
+ dot? ( media-gfx/graphviz )
+ enchant? ( app-text/enchant:2 )
+ gnumeric? ( app-office/gnumeric )
+ html? ( dev-tex/html2latex )
+ hunspell? ( app-text/hunspell )
+ l10n_he? (
+ dev-tex/culmus-latex
+ dev-texlive/texlive-langarabic
+ )
+ latex? (
+ app-text/dvipng
+ app-text/ghostscript-gpl
+ app-text/ps2eps
+ app-text/texlive
+ dev-texlive/texlive-fontsrecommended
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-mathscience
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-plaingeneric
+ || (
+ dev-tex/latex2html
+ dev-tex/hevea
+ dev-tex/tex4ht[java]
+ dev-tex/tth
+ )
+ )
+ rcs? ( dev-vcs/rcs )
+ rtf? (
+ app-text/unrtf
+ dev-tex/html2latex
+ dev-tex/latex2rtf
+ )
+ svg? ( || (
+ gnome-base/librsvg
+ media-gfx/inkscape
+ ) )
+"
+DEPEND="${RDEPEND}"
+# bc needed http://comments.gmane.org/gmane.editors.lyx.devel/137498 and bug #787839
+BDEPEND="
+ app-alternatives/bc
+ virtual/pkgconfig
+ dev-qt/qttools[linguist]
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( ANNOUNCE NEWS README RELEASE-NOTES UPGRADING )
+
+FONT_S="${S}/lib/fonts"
+FONT_SUFFIX="ttf"
+
+PATCHES=(
+ "${FILESDIR}"/lyx-2.4.0-fix-hunspell.patch
+ # Try first with xdg-open before hardcoded commands
+ # Patch from Debian using a similar approach to Fedora
+ "${FILESDIR}"/lyx-2.4.0-prefer-xdg-open.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ font_pkg_setup
+}
+
+src_prepare() {
+ sed "s:python -tt:${EPYTHON} -tt:g" -i lib/configure.py || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ #bug 221921
+ export VARTEXFONTS="${T}"/fonts
+
+ local mycmakeargs=(
+ -DLYX_INSTALL=ON
+ -DLYX_USE_QT=QT6
+ -DLYX_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DLYX_CXX_FLAGS_EXTRA="${CXXFLAGS}"
+
+ -DLYX_NLS=$(usex nls)
+ -DLYX_ASPELL=$(usex aspell)
+ -DLYX_ENCHANT=$(usex enchant)
+ -DLYX_HUNSPELL=$(usex hunspell)
+
+ # external dependencies
+ -DLYX_EXTERNAL_Z=ON
+ -DLYX_EXTERNAL_ICONV=ON
+ -DLYX_EXTERNAL_HUNSPELL=ON
+ -DLYX_EXTERNAL_MYTHES=ON
+ -DLYX_EXTERNAL_BOOST=ON
+ -DLYX_PROGRAM_SUFFIX=OFF
+
+ # debug control
+ -DLYX_NO_OPTIMIZE=OFF
+ -DLYX_RELEASE=ON
+ -DLYX_DEBUG=OFF
+ -DLYX_DEBUG_GLIBC=OFF
+ -DLYX_STDLIB_DEBUG=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ newicon -s 32 "development/Win32/packaging/icons/lyx_32x32.png" ${PN}.png
+ doicon -s 48 "lib/images/lyx.png"
+ doicon -s scalable "lib/images/lyx.svg"
+
+ # fix for bug 91108
+ if use latex; then
+ dosym -r /usr/share/lyx/tex /usr/share/texmf-site/tex/latex/lyx
+ fi
+
+ # fonts needed for proper math display, see also bug #15629
+ font_src_install
+
+ python_fix_shebang "${ED}"/usr/share/${PN}
+
+ if use hunspell; then
+ dosym ../myspell /usr/share/lyx/dicts
+ dosym ../myspell /usr/share/lyx/thes
+ fi
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+ xdg_pkg_postinst
+
+ # fix for bug 91108
+ if use latex ; then
+ texhash || die
+ fi
+
+ optfeature "handling more fonts" dev-texlive/texlive-fontsextra
+}
+
+pkg_postrm() {
+ font_pkg_postrm
+ xdg_pkg_postrm
+
+ if use latex ; then
+ texhash || die
+ fi
+}