summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-10 14:36:19 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-10 14:36:19 +0200
commitea855e7d714adb9975351170ca8a7af03a0183e5 (patch)
tree073797203a9ac9e5387c0fdfa30f63469682b66f /app-pda
parentapp-pda/libimobiledevice: Drop 1.2.0-r1 (diff)
downloadgentoo-ea855e7d714adb9975351170ca8a7af03a0183e5.tar.gz
gentoo-ea855e7d714adb9975351170ca8a7af03a0183e5.tar.bz2
gentoo-ea855e7d714adb9975351170ca8a7af03a0183e5.zip
app-pda/libplist: Drop 2.0.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libplist/Manifest1
-rw-r--r--app-pda/libplist/libplist-2.0.0.ebuild88
2 files changed, 0 insertions, 89 deletions
diff --git a/app-pda/libplist/Manifest b/app-pda/libplist/Manifest
index 9671223444f2..9004ee690105 100644
--- a/app-pda/libplist/Manifest
+++ b/app-pda/libplist/Manifest
@@ -1,2 +1 @@
-DIST libplist-2.0.0.tar.bz2 421405 BLAKE2B 2f6e22c871ad3b5ace2a2c6aab09706e8a8c1759f1656c5c07164e5b89a1b5eae24d2d7472e0dcca7eddd96b641715acfe5a0a791b0b994ec5fbcdf70627acf9 SHA512 81508bf6773483528816725c3b5b868563b84fd7810999404072e5ea9efa7fc9f11ef997f32208e4421aa26b15edd0c65f87c67c1472e8c4e356f1e9fe7740ee
DIST libplist-2.1.0.tar.bz2 120602 BLAKE2B 8abfe3c295c4ebd242f2c4d49c80d1f214097df84f1d2fcf2696519bbbca4e8a5ce13c04690ac64fd981f84d585df25fc65c268a4e4f4092319053583e67736c SHA512 23156e882835bb0b894a05b57018b5e76f9f8f8f4b1d3fdad7b1970d2ef695033c98de74a1fa81bdf0829742a058fd65075cebc1512313d2be42e2f5367274be
diff --git a/app-pda/libplist/libplist-2.0.0.ebuild b/app-pda/libplist/libplist-2.0.0.ebuild
deleted file mode 100644
index c1aa521a377c..000000000000
--- a/app-pda/libplist/libplist-2.0.0.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit autotools eutils ltprune python-r1
-
-DESCRIPTION="Support library to deal with Apple Property Lists (Binary & XML)"
-HOMEPAGE="http://www.libimobiledevice.org/"
-SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0/3.1.0" # based on SONAME of libplist.so
-KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 x86"
-IUSE="python static-libs"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- python? ( >=dev-python/cython-0.17[${PYTHON_USEDEP}] )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DOCS=( AUTHORS NEWS README )
-
-BUILD_DIR="${S}_build"
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- local ECONF_SOURCE=${S}
- local myeconfargs=( $(use_enable static-libs static) )
-
- do_configure() {
- mkdir -p "${BUILD_DIR}" || die
- pushd "${BUILD_DIR}" >/dev/null || die
- econf "${myeconfargs[@]}" "${@}"
- popd >/dev/null || die
- }
-
- do_configure_python() {
- local -x PYTHON_LDFLAGS="$(python_get_LIBS)"
- do_configure "$@"
- }
-
- do_configure --without-cython
- use python && python_foreach_impl do_configure_python
-}
-
-src_compile() {
- python_compile() {
- emake -C "${BUILD_DIR}"/cython -j1 \
- VPATH="${S}/cython:${native_builddir}/cython" \
- plist_la_LIBADD="${native_builddir}/src/libplist.la"
- }
-
- local native_builddir=${BUILD_DIR}
- pushd "${BUILD_DIR}" >/dev/null || die
- emake -j1
- use python && python_foreach_impl python_compile
- popd >/dev/null || die
-}
-
-src_install() {
- python_install() {
- emake -C "${BUILD_DIR}/cython" -j1 \
- VPATH="${S}/cython:${native_builddir}/cython" \
- DESTDIR="${D}" install
- }
-
- local native_builddir=${BUILD_DIR}
- pushd "${BUILD_DIR}" >/dev/null || die
- emake -j1 DESTDIR="${D}" install
- use python && python_foreach_impl python_install
- popd >/dev/null || die
-
- einstalldocs
-
- if use python ; then
- insinto /usr/include/plist/cython
- doins cython/plist.pxd
- fi
- prune_libtool_files --all
-}