summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-05-21 00:27:03 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-05-21 00:27:03 +0200
commit313461f94be9a8ccc0970440a397d4de6f54b9c0 (patch)
treece36bbdf463d5ac7cdfc02fa38b612ce828eefdc /app-portage/elicense
parentsys-kernel/linux-firmware: Speed up src_prepare code. (diff)
downloadgentoo-313461f94be9a8ccc0970440a397d4de6f54b9c0.tar.gz
gentoo-313461f94be9a8ccc0970440a397d4de6f54b9c0.tar.bz2
gentoo-313461f94be9a8ccc0970440a397d4de6f54b9c0.zip
app-portage/elicense: new package
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-portage/elicense')
-rw-r--r--app-portage/elicense/Manifest1
-rw-r--r--app-portage/elicense/elicense-1.0.0.ebuild23
-rw-r--r--app-portage/elicense/elicense-9999.ebuild23
-rw-r--r--app-portage/elicense/metadata.xml12
4 files changed, 59 insertions, 0 deletions
diff --git a/app-portage/elicense/Manifest b/app-portage/elicense/Manifest
new file mode 100644
index 000000000000..5d6c85b7d435
--- /dev/null
+++ b/app-portage/elicense/Manifest
@@ -0,0 +1 @@
+DIST elicense-1.0.0.tar.gz 8719 BLAKE2B 4d9c06cf3229f5a13ec246080098e1f8389afa951bf95cce48159509c160bbc43da511ec0936139c282f59514419fc4911b6a7c9c89bdce18ccda8d175baacae SHA512 5b81e9256486f42f9060d29c7ba3c9101a23a60bfc1ceed978172a2d6feeda22e42486b950ee181a3fe5166e69cabc0ba29043811076865b38f687c0258e9aa8
diff --git a/app-portage/elicense/elicense-1.0.0.ebuild b/app-portage/elicense/elicense-1.0.0.ebuild
new file mode 100644
index 000000000000..9d3210d94d94
--- /dev/null
+++ b/app-portage/elicense/elicense-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/Whissi/elicense.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Whissi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="A common interface to Gentoo package managers"
+HOMEPAGE="https://github.com/Whissi/elicense"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.3.62[${PYTHON_USEDEP}]"
diff --git a/app-portage/elicense/elicense-9999.ebuild b/app-portage/elicense/elicense-9999.ebuild
new file mode 100644
index 000000000000..9d3210d94d94
--- /dev/null
+++ b/app-portage/elicense/elicense-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/Whissi/elicense.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Whissi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="A common interface to Gentoo package managers"
+HOMEPAGE="https://github.com/Whissi/elicense"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.3.62[${PYTHON_USEDEP}]"
diff --git a/app-portage/elicense/metadata.xml b/app-portage/elicense/metadata.xml
new file mode 100644
index 000000000000..a100a0b4e8f7
--- /dev/null
+++ b/app-portage/elicense/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">Whissi/elicense</remote-id>
+ </upstream>
+</pkgmetadata>