summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-18 18:20:25 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-18 18:26:44 +0100
commit98c8f2a8a2a47606f677ab582ed942b457ded8e9 (patch)
tree640ecd1947bc2c784c7dd7bfe112ee603ec9da54 /app-portage/flaggie
parentwww-plugins/chrome-binary-plugins: automated update (110.0.5481.38_beta) (diff)
downloadgentoo-98c8f2a8a2a47606f677ab582ed942b457ded8e9.tar.gz
gentoo-98c8f2a8a2a47606f677ab582ed942b457ded8e9.tar.bz2
gentoo-98c8f2a8a2a47606f677ab582ed942b457ded8e9.zip
app-portage/flaggie: Bump to 0.99.0 (prerelease)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/flaggie')
-rw-r--r--app-portage/flaggie/Manifest1
-rw-r--r--app-portage/flaggie/flaggie-0.99.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-portage/flaggie/Manifest b/app-portage/flaggie/Manifest
index 1d01791c764a..a6b60eb28f63 100644
--- a/app-portage/flaggie/Manifest
+++ b/app-portage/flaggie/Manifest
@@ -1 +1,2 @@
DIST flaggie-0.2.1.tar.bz2 16767 BLAKE2B fea0fbc505bfa97e7bee2c05f0cc19077b9b23a021b01aafa2c4b064466677f9dd4ae95c36f6de65b4ad07c5046d539ceb0cb667dcb791b60410d7a5e688813f SHA512 3f273ebeceaaedce7a3807126fb3f450e420338a883440066d06a4d6a95b63bd538bb5da882fea23e0d390b28a83f50375dbda2624f656327775b2b700f2b2e4
+DIST flaggie-0.99.0.gh.tar.gz 15210 BLAKE2B 59d8d877ed98580b8631f72be531c21cb8ba9bf482ed3c4ceca6bb8f10fb9873124258eb3aad51b56f2e4f3d8c54fc192c9909bf5f48cbf6127aa74a9f23b377 SHA512 41fcac02b1eb0588802d364da468c5fd9d223e9d21dcbb17a1802953ca74704bfe9d2b764e7be8a8748a8dfcc5172d8395f801c4f36ab836c5b75a08886e1971
diff --git a/app-portage/flaggie/flaggie-0.99.0.ebuild b/app-portage/flaggie/flaggie-0.99.0.ebuild
new file mode 100644
index 000000000000..8a7cfc3fa1d2
--- /dev/null
+++ b/app-portage/flaggie/flaggie-0.99.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A smart CLI mangler for package.* files"
+HOMEPAGE="
+ https://github.com/projg2/flaggie/
+"
+SRC_URI="
+ https://github.com/projg2/flaggie/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ app-portage/gentoopm[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-vcs/git
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ ewarn "This is a preview release of flaggie 1.x. It it not fully featured"
+ ewarn "yet and it may have significant bugs. Please back your /etc/portage"
+ ewarn "up before using it. Verify the results using --pretend."
+}