summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-29 17:26:13 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-29 17:52:24 +0200
commitb364a0971bc840ce7c6097135c4f059e68f540d5 (patch)
treeae365938b565b3f8734e3140a08eb90981cf127b /app-portage/unsymlink-lib
parentmedia-plugins/gst-plugins-ximagesrc: amd64 stable wrt bug #728940 (diff)
downloadgentoo-b364a0971bc840ce7c6097135c4f059e68f540d5.tar.gz
gentoo-b364a0971bc840ce7c6097135c4f059e68f540d5.tar.bz2
gentoo-b364a0971bc840ce7c6097135c4f059e68f540d5.zip
app-portage/unsymlink-lib: Bump to v18
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/unsymlink-lib')
-rw-r--r--app-portage/unsymlink-lib/Manifest1
-rw-r--r--app-portage/unsymlink-lib/unsymlink-lib-18.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-portage/unsymlink-lib/Manifest b/app-portage/unsymlink-lib/Manifest
index eaf132652fad..7b3a42c89418 100644
--- a/app-portage/unsymlink-lib/Manifest
+++ b/app-portage/unsymlink-lib/Manifest
@@ -1 +1,2 @@
DIST unsymlink-lib-17.tar.gz 10550 BLAKE2B 036cf63e3619113763f01086fbd952fb2a6efda4d4f4989a5d8cadc0d47b439cba0fab84d53336d615ccbec4e0815519cd4709162f11bbf5fa42c770b928f6f2 SHA512 b981419e320da74f983c184f2b9739b0f1cdae7adf1b9d29c3221b7d010432f6844ff3bdf93793b2f701e2337acebc28a6bd2df0763a081cd8e53a8400aaea42
+DIST unsymlink-lib-18.tar.gz 10807 BLAKE2B 0c15ba8fadc96641139db68068c6402f24bd9129b452a8996c393ee899b274e7a5c96d58c2745b74ec3dbb469008a6756041b153abbbe3f29aca5f93c8700834 SHA512 bb08f1c35046d756aee752c7cd28f8eb93c562587f2fbc0070817c11fd42f3d12fade9c8ad29c508813e10993f5b622c9d33da52e49dfa7e16b1997a72d491f5
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-18.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-18.ebuild
new file mode 100644
index 000000000000..03c0f831738d
--- /dev/null
+++ b/app-portage/unsymlink-lib/unsymlink-lib-18.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-single-r1
+
+DESCRIPTION="Convert your system to SYMLINK_LIB=no"
+HOMEPAGE="https://github.com/mgorny/unsymlink-lib"
+SRC_URI="https://github.com/mgorny/unsymlink-lib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# tests are docker-based, you need a running docker daemon and you
+# should expect leftover images
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ sys-apps/portage[${PYTHON_MULTI_USEDEP}]
+ ')"
+
+src_install() {
+ python_doscript unsymlink-lib
+ dodoc README
+}