summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-27 16:15:11 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-27 16:15:20 +0200
commit54e33b91fda61143b1223bcaea8b917f88c26691 (patch)
treeee1abc02669e8ba97487047b6705d77f04e70a6a /app-portage
parentdev-cpp/asio: drop 1.22.1 (diff)
downloadgentoo-54e33b91fda61143b1223bcaea8b917f88c26691.tar.gz
gentoo-54e33b91fda61143b1223bcaea8b917f88c26691.tar.bz2
gentoo-54e33b91fda61143b1223bcaea8b917f88c26691.zip
app-portage/g-octave: update EAPI 7 -> 8, PEP517, enable py3_{10,11}
Closes: https://bugs.gentoo.org/845564 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/g-octave/Manifest1
-rw-r--r--app-portage/g-octave/g-octave-0.4.1-r8.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-portage/g-octave/Manifest b/app-portage/g-octave/Manifest
index f50b4166cf1e..a1b699127f75 100644
--- a/app-portage/g-octave/Manifest
+++ b/app-portage/g-octave/Manifest
@@ -1,3 +1,4 @@
DIST g-octave-0.4.1.tar.gz 52285 BLAKE2B d1e39931471c527c5542683c976487c56bca2a4666a437e110fa41b504287c0dd87aad94bf98298544c374c6d3faa0722fb3fab43228c56425be19b450ae0dd4 SHA512 424b95e626981aa5685795ffb3df1a1d608e5293adba074cc67f7dcf08d4a0c94a0174005f97a8da1ba1ae4233299e6a530af96ba3b9fd0d8b224915e947efb3
+DIST g-octave-db-b48055c.tar.gz 48280 BLAKE2B 21d507ec3a4484363457105667e54646b19b7a43b2ae303527faf19748495d31d7b23caab839f0e45c03806e1c7c390312c778f3f9dc2a9e2be1282b9b889514 SHA512 095a3327c1b00686a66c69592842a0258509d7a12e3e91bf4ba59c40c7f326c4f4e3355fe06fb3d8f14e3581c8e7e7c9b7c69b6c3b498943dfad8e68a028eb43
DIST g-octave-db-bdf02cb.tar.gz 39836 BLAKE2B fadc374e69bbf785f9e9ecae02eeba6f1c048d11503e5d97db2b4cc65c820ec829615be72ce823ef44ecb0e59e1b68dd40f7310d19d0b7706a2ff47ab95c0851 SHA512 5eae00e18b6d4633ed0feda3a2eea6b36da049c133bcd49e54481443ff435bfcab0f303ab9f0e8c3f48fad707625ee13b4564c510d89fa196e737c7599ea5fa6
DIST g-octave-patches-0.4.1-r7.tar.xz 8800 BLAKE2B 514b154d7cbb816f15d88a2efe0d0b8503a5a09dedfcc79ab61fdb2fca8be193752ffb477ad7ea7be167e341a91e8d83c5b70fa20ed9d55da6f668acc8743e6c SHA512 cb03afd16bb7f2f0ddf2c4f11bdde2748b8ee0124642cfed4697e19adda30b141b3217afa55e996acf3e295d06af0636ba235a631039e65ca7920eef3243e267
diff --git a/app-portage/g-octave/g-octave-0.4.1-r8.ebuild b/app-portage/g-octave/g-octave-0.4.1-r8.ebuild
new file mode 100644
index 000000000000..60060793e870
--- /dev/null
+++ b/app-portage/g-octave/g-octave-0.4.1-r8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DB_COMMIT="b48055c9b54ef4fb941a07eb3b763c868ef4e0ca"
+DB_DIR="rafaelmartins-${PN}-db-${DB_COMMIT:0:7}"
+
+DESCRIPTION="A tool that generates and installs ebuilds for Octave-Forge"
+HOMEPAGE="https://github.com/rafaelmartins/g-octave"
+SRC_URI="https://github.com/downloads/rafaelmartins/${PN}/${P}.tar.gz
+ https://github.com/rafaelmartins/${PN}-db/archive/${DB_COMMIT}.tar.gz ->
+ ${PN}-db-${DB_COMMIT:0:7}.tar.gz
+ https://dev.gentoo.org/~rafaelmartins/distfiles/${PN}-patches-${PV}-r7.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-apps/portage"
+
+PATCHES=(
+ "${WORKDIR}/${PN}-patches-${PV}-r7"
+)
+
+distutils_enable_sphinx docs
+
+pkg_config() {
+ local db="$(g-octave --config db)"
+ mkdir -p "${db}" || die 'mkdir failed.'
+ einfo "Extracting g-octave database files to: ${db}"
+ tar -xzf "${EROOT}/usr/share/g-octave/${PN}-db-${DB_COMMIT:0:7}.tar.gz" -C "${db}" || die 'tar failed.'
+ rm -r "${db}"/{patches,octave-forge,info.json,manifest.json,timestamp} || die 'rm db files failed.'
+ mv "${db}/${DB_DIR}"/* "${db}" || die 'mv failed.'
+ rm -r "${db}/${DB_DIR}" || die 'rm db dir failed.'
+}
+
+python_prepare_all() {
+ sed -i -e 's/^has_fetch.*$/has_fetch = False/' scripts/g-octave \
+ || die 'failed to patch the g-octave main script'
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ doman ${PN}.1
+ insinto /usr/share/g-octave
+ doins "${DISTDIR}"/${PN}-db-${DB_COMMIT:0:7}.tar.gz
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ "${EPYTHON}" scripts/run_tests.py || die 'test failed.'
+}
+
+pkg_postinst() {
+ elog
+ elog 'To be able to use g-octave with the shipped package database, please'
+ elog 'edit your configuration file, clean your db directory and run:'
+ elog " emerge --config =${PF}"
+ elog
+ elog "If you are upgrading from =${PN}-0.3, please read this:"
+ elog "http://g-octave.readthedocs.org/en/latest/upgrading/#from-0-3-to-0-4"
+ elog
+ elog 'Please install the package manager that you want to use before run g-octave'
+ elog
+}