summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-09 02:15:33 +0000
committerSam James <sam@gentoo.org>2024-01-09 02:15:33 +0000
commit7a21445ac7cb9a2a6429555a3820f6d30cb6582d (patch)
tree3ec2feb7e9168594fcc4a7d6876aca48fe85a70c /app-portage
parentdev-libs/libisoburn: autoreconf for newer libtool (diff)
downloadgentoo-7a21445ac7cb9a2a6429555a3820f6d30cb6582d.tar.gz
gentoo-7a21445ac7cb9a2a6429555a3820f6d30cb6582d.tar.bz2
gentoo-7a21445ac7cb9a2a6429555a3820f6d30cb6582d.zip
app-portage/elt-patches: add 99999999
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/elt-patches/elt-patches-20231228.ebuild22
-rw-r--r--app-portage/elt-patches/elt-patches-99999999.ebuild37
2 files changed, 54 insertions, 5 deletions
diff --git a/app-portage/elt-patches/elt-patches-20231228.ebuild b/app-portage/elt-patches/elt-patches-20231228.ebuild
index b1667bd39ced..76e331af750c 100644
--- a/app-portage/elt-patches/elt-patches-20231228.ebuild
+++ b/app-portage/elt-patches/elt-patches-20231228.ebuild
@@ -1,17 +1,29 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="Collection of patches for libtool.eclass"
HOMEPAGE="https://gitweb.gentoo.org/proj/elt-patches.git/"
-SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz
- https://dev.gentoo.org/~vapier/dist/${P}.tar.xz
- https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/elt-patches.git
+ https://github.com/gentoo/elt-patches
+ "
+ inherit git-r3
+else
+ SRC_URI="
+ https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz
+ "
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-linux ~ppc64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-linux ~ppc64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
RDEPEND="sys-apps/gentoo-functions"
BDEPEND="app-arch/xz-utils"
diff --git a/app-portage/elt-patches/elt-patches-99999999.ebuild b/app-portage/elt-patches/elt-patches-99999999.ebuild
new file mode 100644
index 000000000000..76e331af750c
--- /dev/null
+++ b/app-portage/elt-patches/elt-patches-99999999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Collection of patches for libtool.eclass"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elt-patches.git/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/elt-patches.git
+ https://github.com/gentoo/elt-patches
+ "
+ inherit git-r3
+else
+ SRC_URI="
+ https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz
+ "
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-linux ~ppc64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="sys-apps/gentoo-functions"
+BDEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake rootprefix="${EPREFIX}" libdirname="$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" rootprefix="${EPREFIX}" install
+}