summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-12-04 00:26:56 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-12-04 00:26:56 -0500
commit7f87831f3133d2e6a832602d15197fb8cdf31c49 (patch)
tree5f0f689ba2875e46190f4fb263d7e9a7b7e083ed /app-portage
parentnet-misc/yt-dlp: add 2024.12.03 (diff)
downloadgentoo-7f87831f3133d2e6a832602d15197fb8cdf31c49.tar.gz
gentoo-7f87831f3133d2e6a832602d15197fb8cdf31c49.tar.bz2
gentoo-7f87831f3133d2e6a832602d15197fb8cdf31c49.zip
app-portage/iwdevtools: add 0.12.14
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.12.14.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 6aa430b436a2..e9cd78ae4b2f 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1 +1,2 @@
DIST iwdevtools-0.12.13.tar.gz 92069 BLAKE2B aab815edc3a8ba5e57cac7954af3bbb75e66ca605ea0299c5d024fcaf321fe0d00b1b2fb1a22178ab485de1c669220c845ec9b69c94f22ffd925d347b737c47b SHA512 20a3b238fd27d7c57faf2f79705d86359f3dde0b8e59bd4fa63844aea294d539a74a875916a5129f4a774edc9e26b485a5852393f450edb74894f43d5c1cc3a1
+DIST iwdevtools-0.12.14.tar.gz 92477 BLAKE2B ed7291fd686400369a9a9ed8e8a35b310905a494486e65ee98787a746677e744b93070f0f6ebffee72d1da49297ab9c389e40207db1c318e47684bf2d44aef60 SHA512 06525fff14487619a4a7743d53ad49d904922fc955ea7f8d848f97818bb24ca15a56baa29ecb2ff935dc38140ce2e95b126078cf80bbb95c1f6cebd57d1bc6e3
diff --git a/app-portage/iwdevtools/iwdevtools-0.12.14.ebuild b/app-portage/iwdevtools/iwdevtools-0.12.14.ebuild
new file mode 100644
index 000000000000..ec44767eee7c
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.12.14.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools/"
+SRC_URI="
+ https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1:0[readline]
+ dev-libs/libxml2:2
+ sys-apps/coreutils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )
+"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}