summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-07 00:04:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-07 00:23:39 +0100
commitd0ad15ad06bb08cd5f4e9f22b22ea52637d7889a (patch)
tree963f8018c4ee52a5148964b29cd2d8a9b5aac357 /app-portage
parentapp-portage/gentoopm: Update the live ebuild (diff)
downloadgentoo-d0ad15ad06bb08cd5f4e9f22b22ea52637d7889a.tar.gz
gentoo-d0ad15ad06bb08cd5f4e9f22b22ea52637d7889a.tar.bz2
gentoo-d0ad15ad06bb08cd5f4e9f22b22ea52637d7889a.zip
app-portage/gentoopm: Bump to 0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoopm/Manifest1
-rw-r--r--app-portage/gentoopm/gentoopm-0.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-portage/gentoopm/Manifest b/app-portage/gentoopm/Manifest
index f3c236ab7268..dde6c0d3e50f 100644
--- a/app-portage/gentoopm/Manifest
+++ b/app-portage/gentoopm/Manifest
@@ -1 +1,2 @@
DIST gentoopm-0.3.3.tar.gz 38624 BLAKE2B 018be741c6970b17525e56d5acdb23e15c8f78016fddda50ef329ea65b84e085a928e1e5e95c69757530c067c28aa578e9c56b8bd7546d7249a75e9c3cc3b57f SHA512 91ea07035b25bdccd8072c5691690ae0b40b6220a2ea29e4b051aeb8455f200e94569036af42ff2f5d7714344d332e5d71e3ff8dfde811f2aa6b6c1b3a895b21
+DIST gentoopm-0.4.tar.gz 39123 BLAKE2B c8ea81e2d1aa09d3aa838ccb2a1d221e29ba6cf20c5539435a36da058733ee6814864f11a5a96742b371c6d0f2e1ffa269edf197cd30cf4bc7d517f9fa6623cc SHA512 7af0d4d8b3562b009d8897b70b8621d2004e22a16006ec84144544174724757b39e09cbde98ee876adc166947a58e4afa85f752c66d4dbb03ff1d3a52074720f
diff --git a/app-portage/gentoopm/gentoopm-0.4.ebuild b/app-portage/gentoopm/gentoopm-0.4.ebuild
new file mode 100644
index 000000000000..ac0d89b5c90a
--- /dev/null
+++ b/app-portage/gentoopm/gentoopm-0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A common interface to Gentoo package managers"
+HOMEPAGE="https://github.com/mgorny/gentoopm/"
+SRC_URI="
+ https://github.com/mgorny/gentoopm/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ || (
+ >=sys-apps/pkgcore-0.9.4[${PYTHON_USEDEP}]
+ >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}] )"
+PDEPEND="app-eselect/eselect-package-manager"
+
+distutils_enable_tests pytest
+
+python_test() {
+ if has_version ">=sys-apps/pkgcore-0.9.4[${PYTHON_USEDEP}]"; then
+ einfo "Testing against pkgcore ..."
+ PACKAGE_MANAGER=pkgcore epytest
+ fi
+ if has_version ">=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}]"; then
+ einfo "Testing against portage ..."
+ PACKAGE_MANAGER=portage epytest
+ fi
+}