summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2022-06-14 09:12:19 +0200
committerFabian Groffen <grobian@gentoo.org>2022-06-14 09:15:51 +0200
commitec3307e507ccfc092371f8e16ea40ff50557ca9f (patch)
tree14a732c640ff69925ff921553a03bcb5fe21b176 /app-portage
parentdev-libs/libksba: ppc64 stable wrt bug #849068 (diff)
downloadgentoo-ec3307e507ccfc092371f8e16ea40ff50557ca9f.tar.gz
gentoo-ec3307e507ccfc092371f8e16ea40ff50557ca9f.tar.bz2
gentoo-ec3307e507ccfc092371f8e16ea40ff50557ca9f.zip
app-portage/portage-utils-0.94: version bump
Closes: https://bugs.gentoo.org/851138 Closes: https://bugs.gentoo.org/837188 Closes: https://bugs.gentoo.org/836590 Closes: https://bugs.gentoo.org/833942 Closes: https://bugs.gentoo.org/807975 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portage-utils/Manifest1
-rw-r--r--app-portage/portage-utils/portage-utils-0.94.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-portage/portage-utils/Manifest b/app-portage/portage-utils/Manifest
index ce4ba0771fda..df206d400279 100644
--- a/app-portage/portage-utils/Manifest
+++ b/app-portage/portage-utils/Manifest
@@ -2,3 +2,4 @@ DIST portage-utils-0.90.1.tar.xz 1779252 BLAKE2B 27c94694cab84970c0c92e835b9039d
DIST portage-utils-0.90.tar.xz 1776636 BLAKE2B bbacc05aa97c77705ae4fbdb5efde5f1d49a99ac8ed259e026c9a997f43a86551b3a10a397e0c5f1da161d2c0d88afe88e22870705ca39d911c4a98ad13f4928 SHA512 2077061dd7dfd444d4ad38faf5a87aa44392d7747f71d7283b5e2775ce3d714773cd642ea085aea3dd34a715f2c446d42fd64ba42fa99e716e8d843aae3d9682
DIST portage-utils-0.92.tar.xz 1819676 BLAKE2B 01798e3984745140bca1bcc1eda5c2aea7c517bee2656acfe1bd810fc8088ddcb474f2c64fee6832c5e1699e2ec8ad5a9c6d5afba8a2e2b6f1861d49fbf7fcb7 SHA512 7d36263c9c242c8e82786fa12e171a3f396f65520acb8caa91516862615bd71241699ab6c2232122f7009875aa0a10b06b614a842d45afc86e599b39711e12b3
DIST portage-utils-0.93.3.tar.xz 1796828 BLAKE2B cfad7ab27ff2d92f631f4e31012e8903c5fa6113485f727338812059379cdd4a9552d80dc3aef6bb91264c361c0554fe9054a12347e274c4c5c3db66fd36008b SHA512 c1245aa78d236263cd266fc8565312c2ac30cb992037a7b0f26da04ecf2dfeebc85bff653784e186cf2c7d7468e4772fb0bd93bcdb3a37d46e493d000933e5a1
+DIST portage-utils-0.94.tar.xz 1871876 BLAKE2B 1c8fb8bccbcad0e4a6c3e234670d26ffd548edc7173208ababbb29f3b64676e3266c2a0ba88ed1c85fdec983f7d27f14b330f39cde2bb88b833a7c4fbdf41e19 SHA512 13178c3286a8b94cf04b45b1d9e05bdf2d7d2de16145485b9b6d4673c0c235ee0713c4999a05ebee9561d17355d2d34ac4fe1683049be20af4065c8c70a2a1e3
diff --git a/app-portage/portage-utils/portage-utils-0.94.ebuild b/app-portage/portage-utils/portage-utils-0.94.ebuild
new file mode 100644
index 000000000000..f0936e338fac
--- /dev/null
+++ b/app-portage/portage-utils/portage-utils-0.94.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Small and fast Portage helper tools written in C"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls static openmp +qmanifest +qtegrity"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage-utils.git"
+else
+ SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+RDEPEND="
+ qmanifest? (
+ openmp? (
+ || (
+ >=sys-devel/gcc-4.2:*[openmp]
+ sys-devel/clang-runtime:*[openmp]
+ )
+ )
+ static? (
+ app-crypt/libb2:=[static-libs]
+ dev-libs/openssl:0=[static-libs]
+ sys-libs/zlib:=[static-libs]
+ app-crypt/gpgme:=[static-libs]
+ )
+ !static? (
+ app-crypt/libb2:=
+ dev-libs/openssl:0=
+ sys-libs/zlib:=
+ app-crypt/gpgme:=
+ )
+ )
+ qtegrity? (
+ openmp? (
+ || (
+ >=sys-devel/gcc-4.2:*[openmp]
+ sys-devel/clang-runtime:*[openmp]
+ )
+ )
+ static? (
+ dev-libs/openssl:0=[static-libs]
+ )
+ !static? (
+ dev-libs/openssl:0=
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ --disable-maintainer-mode \
+ --with-eprefix="${EPREFIX}" \
+ $(use_enable qmanifest) \
+ $(use_enable qtegrity) \
+ $(use_enable openmp) \
+ $(use_enable static)
+}