summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-07-23 23:56:09 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-07-24 01:12:10 +0200
commit377a3a0342839aa19980e55b152d5676eb0fec14 (patch)
tree84fa914a325bdcd01d029aab0113cfbbb7f41496 /app-shells
parentapp-shells/pwsh-bin: drop old 7.4.2 (diff)
downloadgentoo-377a3a0342839aa19980e55b152d5676eb0fec14.tar.gz
gentoo-377a3a0342839aa19980e55b152d5676eb0fec14.tar.bz2
gentoo-377a3a0342839aa19980e55b152d5676eb0fec14.zip
app-shells/pwsh-bin: bump to 7.4.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pwsh-bin/Manifest3
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.4.4.ebuild71
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/pwsh-bin/Manifest b/app-shells/pwsh-bin/Manifest
index 6a59757a7b2c..b2777515718a 100644
--- a/app-shells/pwsh-bin/Manifest
+++ b/app-shells/pwsh-bin/Manifest
@@ -1,3 +1,6 @@
DIST powershell-7.4.3-linux-arm32.tar.gz 69113670 BLAKE2B 91cb3037633ea44578d0230f7c36495c83539b708225394d81df9ea63a2a71fa385aad83c453a92e925a5106d12d3a5f4af56765969dc7e808d941cd993a6453 SHA512 623b9fc692bb062506b6d8a2f0236455645a157f03f221603d0e64269a1f890e3ac5691e6789890eac68732cdd9e476187acb96609e83ffe66220718c701dca2
DIST powershell-7.4.3-linux-arm64.tar.gz 68142136 BLAKE2B f24caa93d786097a6b96d3d704dc0f606a288a6bdfc47a99ff7cbca45df2073eb43e159ba3479b1fdee774eab064ce6f42a09a64f73f5b18cb0d034566566180 SHA512 0caf512a3458f46a72c9e192dc00e4598eb1a4368b965c440ba29756dae72798b906f977c66e6354a91a8c0022cb3b0ea6ea5e25be311620badf37e1361b0d18
DIST powershell-7.4.3-linux-x64.tar.gz 70893666 BLAKE2B bc898eeafdf7b0eb2c3c1420b80c83c5810a4f0d4da0338e787fbd4e1f163eb6a93eae8582280f9c3ab023045f3fe3143fa3481cc5fb86424ec4476ffd1ab3a1 SHA512 4bab6bce57db764c90fe4c614e1627bd4618b50ce5049ae9b4815cb989599147d5be4c7d39dbae6134d8df3bc5f1316bea527d8ab0824f4331518d6b00743f8e
+DIST powershell-7.4.4-linux-arm32.tar.gz 69166374 BLAKE2B 8be16e528ddef95422906b1e37d12067ae274d68efd03dd75c1c5b50e947b5ec617084bc0f5168f4f577893956ebdfee3ceb896c918fd149bc844581ff778a0d SHA512 66e822067dfaba1fb24c853c992539d0ec3562cb63513d7f3d5a1ded12bf6dce2d5d31ca0cd32bf6951fafc16b91be8bc3629559897e287b9bb0815f424ea557
+DIST powershell-7.4.4-linux-arm64.tar.gz 68135393 BLAKE2B 12803b407093c9e9a804909c42b4237bd6376caeb174e815d258b3e53da2809f18d953e5103ea7a3ce7edacb2fccd7c668a2709f74e756b4bea8e4083c134228 SHA512 cd451c12b2877948e9c11d203a4cdd5af1791dd7f4ca338e936254c0268a5f93ee238034f5c1784b9472eb60d841548445557246296a0e3ff6973dbb641a43c7
+DIST powershell-7.4.4-linux-x64.tar.gz 70860313 BLAKE2B 8780833ce8afd594503d1e62a9e794de12f7947b41e1823e41e646e1751723b957508efd8987dd8c0e36e8b8bf26ee819240ab38f7169712f108c889c8432eab SHA512 ddafaed9fc2e016e8f354e44709917f7999e16fbf4ad1d1b52b6b4682171b121e772d53bc9da5f6936ef770aa162b9da7f1ad99e337befb878b5bef265e2560f
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.4.4.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.4.4.ebuild
new file mode 100644
index 000000000000..e09b2d5daf99
--- /dev/null
+++ b/app-shells/pwsh-bin/pwsh-bin-7.4.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit wrapper
+
+DESCRIPTION="Cross-platform automation and configuration tool (binary package)"
+HOMEPAGE="https://microsoft.com/powershell/
+ https://github.com/PowerShell/PowerShell/"
+
+BASE_URI="https://github.com/PowerShell/PowerShell/releases/download/"
+SRC_URI="
+ amd64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-x64.tar.gz )
+ arm64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm64.tar.gz )
+ arm? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm32.tar.gz )
+"
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-libs/icu
+ dev-util/lttng-ust:0/2.12
+ sys-libs/pam:0/0
+ sys-libs/zlib:0/1
+ || (
+ dev-libs/openssl-compat:1.0.0
+ =dev-libs/openssl-1.0*:0/0
+ )
+"
+IDEPEND="
+ app-eselect/eselect-pwsh
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ local -a broken_symlinks
+ broken_symlinks=( libcrypto.so.1.0.0 libssl.so.1.0.0 )
+
+ local symlink
+ for symlink in "${broken_symlinks[@]}" ; do
+ if [[ -L "${symlink}" ]] ; then
+ rm "${symlink}" || die "failed to remove ${symlink}"
+ fi
+ done
+
+ local dest="opt/${PN}-${SLOT}"
+ local dest_root="/${dest}"
+
+ insinto "${dest_root}"
+ doins -r .
+
+ fperms 0755 "${dest_root}/pwsh"
+
+ local gentoo_path='PSModulePath="${PSModulePath}:${EPREFIX}/usr/share/GentooPowerShell/Modules:"'
+ make_wrapper "${PN}-${SLOT}" "env ${gentoo_path} ${dest_root}/pwsh"
+}
+
+pkg_postinst() {
+ eselect pwsh update ifunset
+}
+
+pkg_postrm() {
+ eselect pwsh update ifunset
+}