summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-07-03 22:59:50 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-03 22:59:50 +0300
commit9c586fd9f785e43c59097fa35bf61e5f4bef7a12 (patch)
tree4b6aaf2b8082e9532ea29031d1ce36816d07a484 /app-shells
parentapp-shells/mcfly: add 0.9.0 (diff)
downloadgentoo-9c586fd9f785e43c59097fa35bf61e5f4bef7a12.tar.gz
gentoo-9c586fd9f785e43c59097fa35bf61e5f4bef7a12.tar.bz2
gentoo-9c586fd9f785e43c59097fa35bf61e5f4bef7a12.zip
app-shells/zsh-completions: add 0.35.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh-completions/Manifest1
-rw-r--r--app-shells/zsh-completions/zsh-completions-0.35.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-shells/zsh-completions/Manifest b/app-shells/zsh-completions/Manifest
index 84fdecb48bea..8c6a90e53dd9 100644
--- a/app-shells/zsh-completions/Manifest
+++ b/app-shells/zsh-completions/Manifest
@@ -1 +1,2 @@
DIST zsh-completions-0.34.0.tar.gz 304543 BLAKE2B 75afed3059e889f92843099ad3eddae1f939a7d9a46d87a8048c5742b44699c2da13a9c2ea00ca2ea02898472199f064c420aac8943338e3b22189a7cc0d23b4 SHA512 643e967a77ab708c6316a9b43edd8b411f133aa4abe10bf69d3f5e545b2128423ad80d3509e7f9077b30cb8a83f60fe8d4355ed0a697dadffe1e1aaac6597c04
+DIST zsh-completions-0.35.0.tar.gz 329686 BLAKE2B 22b4dff55749852a41373a8d96b01963f47dc1fbee0f2ff2a21e5ec48e43b022967630dd3ad2dc74793efe1f3bf77d6783161b671730d2e726df913981a676da SHA512 d6ab46db72b311731abca41e82fded954a43a1e13b81deb7b0acf7d85402ef575c69ead66af97dc2c148a1e681f39e48cfcab53993207f2b786bfe20228587e6
diff --git a/app-shells/zsh-completions/zsh-completions-0.35.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.35.0.ebuild
new file mode 100644
index 000000000000..0e09938f1de7
--- /dev/null
+++ b/app-shells/zsh-completions/zsh-completions-0.35.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="Apache-2.0 BSD MIT ZSH"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+}
+
+pkg_postinst() {
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+}