summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-23 21:22:51 +0100
committerSam James <sam@gentoo.org>2023-06-23 21:22:51 +0100
commitb88d4e453d7bf2b6e5d8f4c27df64197fdcc816c (patch)
tree7c2655c1a9437dbc50b1f2f37811f27996122ccb /app-text/a2ps
parentapp-text/a2ps: drop 4.14-r8, 4.15.2, 4.15.3 (diff)
downloadgentoo-b88d4e453d7bf2b6e5d8f4c27df64197fdcc816c.tar.gz
gentoo-b88d4e453d7bf2b6e5d8f4c27df64197fdcc816c.tar.bz2
gentoo-b88d4e453d7bf2b6e5d8f4c27df64197fdcc816c.zip
app-text/a2ps: add 4.15.5
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/a2ps')
-rw-r--r--app-text/a2ps/Manifest1
-rw-r--r--app-text/a2ps/a2ps-4.15.5.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/app-text/a2ps/Manifest b/app-text/a2ps/Manifest
index 1b54b26477ac..a19c0bdc7135 100644
--- a/app-text/a2ps/Manifest
+++ b/app-text/a2ps/Manifest
@@ -1 +1,2 @@
DIST a2ps-4.15.4.tar.gz 3570970 BLAKE2B 96355c3e656199a6daebc7d311d85f9c124080db8d92e6fdc502bedf06c547e886fed8335f6ce01df04ee23972fb93ccf4c2614294dea63f1bf5eccd95f37a04 SHA512 aac3dfed21919682afa688b7315eeea012c5d496aad163b801021ed81d6056362d149745dcf48a99d139909c2ec796ce56bd4e63adb103d746ad89c691ea7779
+DIST a2ps-4.15.5.tar.gz 3571724 BLAKE2B 7c352b72c537f8519cafb7993595d902e1dfeae49207936c365b0ea3813ffff973c5f5e2bb63a4cffa3c665990d95c8a8e339c87d9eac25fa24e364b8b705bae SHA512 e9953659139a46aed46e190d5485382a9e396ae8bbbe59edb78ab3110e7839a764e3cb6ff94f5f36e6e91fcaf85f6352376e0b4a0e0141f24e098fa334b5015e
diff --git a/app-text/a2ps/a2ps-4.15.5.ebuild b/app-text/a2ps/a2ps-4.15.5.ebuild
new file mode 100644
index 000000000000..db63721729f2
--- /dev/null
+++ b/app-text/a2ps/a2ps-4.15.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools elisp-common
+
+DESCRIPTION="Any to PostScript filter"
+HOMEPAGE="https://www.gnu.org/software/a2ps/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cjk emacs latex nls static-libs vanilla"
+
+# a2ps-lpr-wrapper needs bash
+RDEPEND="
+ app-text/ghostscript-gpl
+ app-text/libpaper:=
+ >=app-text/psutils-1.17
+ app-text/wdiff
+ app-shells/bash:*
+ dev-libs/boehm-gc
+ >=sys-apps/coreutils-6.10-r1
+ emacs? ( >=app-editors/emacs-23.1:* )
+ latex? ( virtual/latex-base )
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-alternatives/yacc
+ >=dev-util/gperf-2.7.2
+ nls? ( sys-devel/gettext )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+
+ use vanilla || eapply "${FILESDIR}"/${PN}-4.15-stdout.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ export LANG=C LC_ALL=C
+
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ --sysconfdir="${EPREFIX}"/etc/a2ps \
+ $(use_enable nls) \
+ COM_netscape=no \
+ COM_acroread=no \
+ $(usev !latex COM_latex=no) \
+ $(usev !emacs EMACS=no)
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ lispdir="${EPREFIX}${SITELISP}"/${PN} \
+ install
+
+ newdoc "${ED}"/usr/share/a2ps/README README.a2ps
+ newdoc "${ED}"/usr/share/a2ps/ppd/README README.a2ps.ppd
+ newdoc "${ED}"/usr/share/ogonkify/README README.ogonkify
+
+ rm -f "${ED}"/usr/share/{a2ps,a2ps/ppd,ogonkify}/README || die
+
+ find "${ED}" -name '*.la' -delete || die
+
+ use emacs && elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+
+ dodoc ANNOUNCE AUTHORS ChangeLog FAQ NEWS README* THANKS TODO
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}