summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/enchant
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/enchant')
-rw-r--r--app-text/enchant/Manifest1
-rw-r--r--app-text/enchant/enchant-1.6.0.ebuild55
-rw-r--r--app-text/enchant/metadata.xml10
3 files changed, 66 insertions, 0 deletions
diff --git a/app-text/enchant/Manifest b/app-text/enchant/Manifest
new file mode 100644
index 000000000000..5a6d052e37c4
--- /dev/null
+++ b/app-text/enchant/Manifest
@@ -0,0 +1 @@
+DIST enchant-1.6.0.tar.gz 607018 SHA256 2fac9e7be7e9424b2c5570d8affe568db39f7572c10ed48d4e13cddf03f7097f SHA512 0ca1634bb783df51512df4abecc89abdadee6baf7330d6e5f90cc15d10779896a3521a1c079ecc07e4df4f7a018ce398cca9d0125a7845a314a059840ebc9137 WHIRLPOOL f6677a11f1d05e210cbd6a7b13f3987ea93b3f1e73537b048093c14686b0310e75a89fdb8798ad0ed386a7e1cd793f60820006df8c1f7919c46c7245ee6a74c9
diff --git a/app-text/enchant/enchant-1.6.0.ebuild b/app-text/enchant/enchant-1.6.0.ebuild
new file mode 100644
index 000000000000..1e8800f61b82
--- /dev/null
+++ b/app-text/enchant/enchant-1.6.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="Spellchecker wrapping library"
+HOMEPAGE="http://www.abisource.com/enchant/"
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="aspell +hunspell static-libs zemberek"
+
+COMMON_DEPENDS="dev-libs/glib:2
+ aspell? ( app-text/aspell )
+ hunspell? ( >=app-text/hunspell-1.2.1 )
+ zemberek? ( dev-libs/dbus-glib )"
+
+RDEPEND="${COMMON_DEPENDS}
+ zemberek? ( app-text/zemberek-server )"
+
+DEPEND="${COMMON_DEPENDS}
+ virtual/pkgconfig"
+
+REQUIRED_USE="|| ( hunspell aspell zemberek )"
+
+DOCS="AUTHORS BUGS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+
+src_prepare() {
+ sed -i \
+ -e 's:noinst_PROGRAMS:check_PROGRAMS:' \
+ tests/Makefile.am || die
+ AT_M4DIR=ac-helpers eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable aspell) \
+ $(use_enable hunspell myspell) \
+ $(use_with hunspell system-myspell) \
+ $(use_enable static-libs static) \
+ $(use_enable zemberek) \
+ --disable-ispell \
+ --with-myspell-dir="${EPREFIX}"/usr/share/myspell/
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}
diff --git a/app-text/enchant/metadata.xml b/app-text/enchant/metadata.xml
new file mode 100644
index 000000000000..d74743a19905
--- /dev/null
+++ b/app-text/enchant/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome-office</herd>
+ <use>
+ <flag name="aspell">Adds support for <pkg>app-text/aspell</pkg> spell checker</flag>
+ <flag name="hunspell">Adds support for <pkg>app-text/hunspell</pkg> spell checker</flag>
+ <flag name="zemberek">Adds support for <pkg>app-text/zemberek-server</pkg> spell checker server</flag>
+ </use>
+</pkgmetadata>