summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-05-03 11:30:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-05-03 13:30:54 +0200
commit198021915b9bf7a31df3fe8837d03939aec45d9a (patch)
tree532d1112293f70e23583885fdbbdf5cebfe90da5 /app-text/libmwaw/libmwaw-0.3.22.ebuild
parentnet-misc/smb4k: add 3.2.1 (diff)
downloadgentoo-198021915b9bf7a31df3fe8837d03939aec45d9a.tar.gz
gentoo-198021915b9bf7a31df3fe8837d03939aec45d9a.tar.bz2
gentoo-198021915b9bf7a31df3fe8837d03939aec45d9a.zip
app-text/libmwaw: 0.3.22 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/libmwaw/libmwaw-0.3.22.ebuild')
-rw-r--r--app-text/libmwaw/libmwaw-0.3.22.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-text/libmwaw/libmwaw-0.3.22.ebuild b/app-text/libmwaw/libmwaw-0.3.22.ebuild
new file mode 100644
index 000000000000..2c2ad8452cba
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.22.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc tools"
+
+DEPEND="
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+
+ # Refresh stale libtool, bug #814512
+ eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ local myeconfargs=(
+ --enable-zip
+ --disable-werror
+ $(use_with doc docs)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}