summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/llpp/llpp-18.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/llpp/llpp-18.ebuild')
-rw-r--r--app-text/llpp/llpp-18.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/app-text/llpp/llpp-18.ebuild b/app-text/llpp/llpp-18.ebuild
new file mode 100644
index 000000000000..4bfb26a9760c
--- /dev/null
+++ b/app-text/llpp/llpp-18.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs vcs-snapshot
+
+DESCRIPTION="graphical PDF viewer which aims to superficially resemble less(1)"
+HOMEPAGE="http://repo.or.cz/w/llpp.git"
+#SRC_URI="http://repo.or.cz/w/llpp.git/snapshot/23585c732e608b486dffd2c210dc2cab43b1d4cb.tar.gz -> ${P}.tar.gz"
+SRC_URI="http://dev.gentoo.org/~xmw/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+ocamlopt static"
+
+LIB_DEPEND=">app-text/mupdf-1.3_p20140118:0=[static-libs]
+ media-libs/openjpeg:2[static-libs]
+ media-libs/freetype:2[static-libs]
+ media-libs/jbig2dec[static-libs]
+ sys-libs/zlib[static-libs]
+ virtual/jpeg:0[static-libs]
+ x11-libs/libX11[static-libs]"
+RDEPEND="x11-misc/xsel
+ !static? ( ${LIB_DEPEND//\[static-libs]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND}
+ app-arch/bzip2[static-libs]
+ media-libs/libXcm[static-libs]
+ x11-libs/libXau[static-libs]
+ x11-libs/libXdmcp[static-libs]
+ x11-libs/libXmu[static-libs] )
+ dev-lang/ocaml[ocamlopt?]
+ dev-ml/lablgl[glut,ocamlopt?]"
+
+RESTRICT="!ocamlopt? ( strip )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-11-WM_CLASS.patch
+}
+
+src_compile() {
+ local ocaml=$(usex ocamlopt ocamlopt.opt ocamlc.opt)
+ local cmo=$(usex ocamlopt cmx cmo)
+ local cma=$(usex ocamlopt cmxa cma)
+ local ccopt="$(freetype-config --cflags ) -O -include ft2build.h -D_GNU_SOURCE"
+ if use static ; then
+ local cclib=""
+ local slib=""
+ local spath=( ${EROOT}usr/$(get_libdir) $($(tc-getPKG_CONFIG) --libs-only-L --static mupdf x11 | sed 's:-L::g') )
+ for slib in $($(tc-getPKG_CONFIG) --libs-only-l --static mupdf x11) -ljpeg -ljbig2dec ; do
+ case ${slib} in
+ -lm|-ldl|-lpthread)
+ einfo "${slib}: shared"
+ cclib+="${slib} " ;;
+ *)
+ local ccnew=$(find ${spath} -name "lib${slib/-l}.a")
+ einfo "${slib}: use ${ccnew}"
+ cclib+="${ccnew} " ;;
+ esac
+ done
+ else
+ local cclib="$($(tc-getPKG_CONFIG) --libs mupdf x11) -lpthread"
+ fi
+
+ verbose() { echo "$@" >&2 ; "$@" || die ; }
+ verbose ocaml str.cma keystoml.ml < KEYS > help.ml
+ verbose printf 'let version ="%s";;\n' ${PV} >> help.ml
+ verbose ${ocaml} -c -o link.o -ccopt "${ccopt}" link.c
+ verbose ${ocaml} -c -o help.${cmo} help.ml
+ verbose ${ocaml} -c -o utils.${cmo} utils.ml
+ verbose ${ocaml} -c -o wsi.cmi wsi.mli
+ verbose ${ocaml} -c -o wsi.${cmo} wsi.ml
+ verbose ${ocaml} -c -o parser.${cmo} parser.ml
+ verbose ${ocaml} -c -o main.${cmo} -I +lablGL main.ml
+ verbose ${ocaml} $(usex ocamlopt "" -custom) -o llpp -I +lablGL\
+ str.${cma} unix.${cma} lablgl.${cma} link.o \
+ -cclib "${cclib}" \
+ help.${cmo} utils.${cmo} parser.${cmo} wsi.${cmo} main.${cmo}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc KEYS README Thanks fixme
+}