summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-07-29 16:37:08 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-07-29 17:16:57 +0200
commit5c94f0bdeaa951a99d2d7a4d510947808aa416b7 (patch)
treeb42f46ce44006c9dd3688d08bce40648859883d2 /app-text/pandoc-bin
parentapp-text/pandoc-bin: drop old 3.2 (diff)
downloadgentoo-5c94f0bdeaa951a99d2d7a4d510947808aa416b7.tar.gz
gentoo-5c94f0bdeaa951a99d2d7a4d510947808aa416b7.tar.bz2
gentoo-5c94f0bdeaa951a99d2d7a4d510947808aa416b7.zip
app-text/pandoc-bin: bump to 3.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-text/pandoc-bin')
-rw-r--r--app-text/pandoc-bin/Manifest2
-rw-r--r--app-text/pandoc-bin/pandoc-bin-3.3.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/app-text/pandoc-bin/Manifest b/app-text/pandoc-bin/Manifest
index 283620075d14..9f7429d2402b 100644
--- a/app-text/pandoc-bin/Manifest
+++ b/app-text/pandoc-bin/Manifest
@@ -1,2 +1,4 @@
DIST pandoc-3.2.1-linux-amd64.tar.gz 32117390 BLAKE2B a927de6467bf48f18c54f0b9846f0060aada3284ca7b4b77c46f7111b760a62babdc8846e543b55a5c9b1d6eede365888c348cf853ea25e31023790661f8faab SHA512 44f4fcf49e69a4a45c135ea5bfc8fbd41afa59f9f367232fddd1a9141629faacd4b8e29bf90e495d517b9c3830ce392807853886be4188e2fb27a61240c8dea6
DIST pandoc-3.2.1-linux-arm64.tar.gz 34812370 BLAKE2B 7d18f3749bdaf25a0305ba2b6927c2fc64efc9f6c7ee16d1b82bf063ff872e1ed5b22f346fdd45094b4245b0930659e840d8f41de4198d0831a2e4003088a63f SHA512 4bf651ecade55b4b3880a63a97586fb2602a51550c45853a0ebcd59def000095b42018fbbc20a707ade85854c45c88ce38ebb80d5c7f0101e6b465b951f21f0c
+DIST pandoc-3.3-linux-amd64.tar.gz 32140122 BLAKE2B eda93f6a127e40d3ef064604385558fdd4e98c497bd65a845062e6daa988f5bf4cda952a0025835a918b5d7c693d299e4ef7a4244ebce065e48571442f199494 SHA512 4dbf051707fe6d2a6e4d46e32ef000a684edd724059059578950d808114f234bef009725f77b5c9ce44b6feb21bdaf9ac16196bb272b9a79456dd5f67b84cbb9
+DIST pandoc-3.3-linux-arm64.tar.gz 34838805 BLAKE2B a81e590d862aa3c7832425cba67d3622805373dbee5c1a36e52e80326d28251d2076ec95392b0bea62c5154c6f59e2f60d2195b64d0fe6688313437f76f678c4 SHA512 e2c42c2af49dffd05506dc268d929214b85559560140da163145b72dce4dd8fd2f22b8e3278dfdaf0d90f7caba8a8d5a56443362054d508437326b7fc1dfcb93
diff --git a/app-text/pandoc-bin/pandoc-bin-3.3.ebuild b/app-text/pandoc-bin/pandoc-bin-3.3.ebuild
new file mode 100644
index 000000000000..6c205a599708
--- /dev/null
+++ b/app-text/pandoc-bin/pandoc-bin-3.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN//-bin/}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Conversion between markup formats (binary package)"
+HOMEPAGE="https://pandoc.org/
+ https://github.com/jgm/pandoc/"
+
+BASE_URI="https://github.com/jgm/${MY_PN}/releases/download/${PV}/${MY_P}"
+SRC_URI="
+ amd64? ( ${BASE_URI}-linux-amd64.tar.gz )
+ arm64? ( ${BASE_URI}-linux-arm64.tar.gz )
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm64"
+IUSE="+pandoc-symlink"
+
+RDEPEND="
+ pandoc-symlink? (
+ !${CATEGORY}/${MY_PN}
+ !app-text/pandoc-cli
+ !dev-haskell/pandoc
+ )
+"
+
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+QA_PRESTRIPPED="${QA_FLAGS_IGNORED}"
+
+src_unpack() {
+ default
+
+ # Manpages are gzipped.
+ unpack "${S}"/share/man/man1/*.1.gz
+}
+
+src_install() {
+ exeinto /usr/bin
+ newexe bin/${MY_PN} ${PN}
+ dosym ${PN} /usr/bin/pandoc-lua-bin
+ dosym ${PN} /usr/bin/pandoc-server-bin
+
+ newman "${WORKDIR}"/${MY_PN}-lua.1 pandoc-lua-bin.1
+ newman "${WORKDIR}"/${MY_PN}-server.1 pandoc-server-bin.1
+ newman "${WORKDIR}"/${MY_PN}.1 ${PN}.1
+
+ if use pandoc-symlink ; then
+ dosym ${PN} /usr/bin/${MY_PN}
+ dosym pandoc-lua-bin /usr/bin/${MY_PN}-lua
+ dosym pandoc-server-bin /usr/bin/${MY_PN}-server
+
+ dosym ${PN}.1 /usr/share/man/man1/${MY_PN}.1
+ dosym pandoc-lua-bin.1 /usr/share/man/man1/${MY_PN}-lua.1
+ dosym pandoc-server-bin.1 /usr/share/man/man1/${MY_PN}-server.1
+ fi
+}